
Expression 3 Interface Primer

Those of you who are totally new to Expression 3 should start here. This page outlines key features of the Expression 3 interface. I've kept the discussions short and will point you to sections of the Expression 3 user manual for addition information on a subject. The user manual is an excellent
source of information and I encourage you to read it. A PDF version of the manual is accessible from the Help section on the Expression 3 menu bar.

If you are familiar with the interface, you can skip this section and move on to lesson 1. I will link back to this page in relevant portions of each lesson for those of you who are somewhat familiar with the interface but just need a quick reminder.

Mac User Substitutions

Throughout the lessons, keyboard shortcuts are given exclusively in PC terminology. Mac users should substitute the Option key when the term Alt is used, and the Command key when the term Ctrl is used.

Introduction to the Expression 3 Interface

Below is a screen capture of the Expression 3 interface, which displays only three of the many palettes available. From top to botton they are the ToolBox, the Paint Style palette and the Strokes palette.

Title Bar: At the top of the interface is the Title Bar which displays the name of the program followed by the name of the currently active document. Nothing spectacular here.

Menu Bar: The menu bar appears below the Title bar. Standard operations such as opening and saving documents are only accessable from the menu bar. I will refer you to menu items in bold, such as File > Preferences, for example. These lessons assume you are familiar with standard
concepts for your particular operating system (Mac or Windows), such as navigating the menu bar.

Palettes: By default, palettes are docked on the left side of the interface. When more palettes are opened than will fit in the space provided, some palettes will collapse to make room. In that case, a maximize button appears to the left of the close button on the Title Bar. Click the maximize
button to expand the palette and another palette will minimize to compensate.

You can remove palettes by clicking the close button on the right side of each palette's title bar. To display a palette, choose the palette from the Window menu on the menu bar or use the palette's shortcut key to toggle between showing and hiding the palette. You'll notice a list of shortcut
keys next to each palette item in the Window menu. Palettes may also be moved from their default location by dragging the palette by it's title bar. See pages 37-38 of the user manual for more information on palettes.

Document Window: The document window is where you create your drawings and it appears to the right of the palettes in the screen shot above. The drawing portion of the document window is referred to as the View Area. The rulers along the top and left side of the view area double as
scrollbars. Hold your mouse over a ruler and, when your mouse pointer changes to a grabbing hand, you can scroll horizontally using the top ruler and vertically using the ruler on the left. Because the rulers double as scrollbars, the rulers cannot be hidden. The rulers also keep track of your mouse
position with lines that move along each ruler as the mouse moves around the view area.

A unit button, in the upper left corner where the rulers meet, allows you to change the rulers unit of measure. The available units are inches (in), millimeters (mm), centimeters (cm), pica (pc) and points (pt). To change the unit of measure, click on the button and choose the unit of measure
from the resulting drop down menu. Expression remembers this setting each time you launch the program until you change it.

In the bottom left corner is the magnification tab. Click and hold this tab to scroll through various magnification levels. The document window will update to display each magnification level as you scroll; release your mouse when you reach the magnification level you want. Other scrolling
options include the Magnification tool on the ToolBox and magnification options from the View menu item. See pages 33-34 of the user manual for zooming options.

The black frame in the center of the document is the document frame which sets the intended output area. The document frame size can be changed (see page 31 of the user manual). You may also see a second, lighter frame which represents the printer paper margin. You can choose to
display or hide the printer paper margin but can't hide the document frame. You can, however, effectively hide the frame by setting it's dimensions (see user manual at page 31) larger than your view area if you find the frame distracting. On the other hand, if you use a stylus and rotate the
document to draw in a manner that is natural to you, you may prefer that the document frame is visible as it helps to identify the documents current state. To rotate the View Area, use the } shortcut to rotate clockwise and { to rotate counterclockwise.

More than one document may be opened at one time. To navigate between documents, use the tabs at the bottom of the document window. These tabs allow you to flip through opened documents and to 'scrub' documents. To 'flip' between documents (meaning to switch between documents in
the order they appear on the tabs) using shortcut keys, press the ] key to flip forward through the documents or the [ key to flip backward through the documents.

'Scrubbing' is a method of checking the smoothness of an action sequence and is useful to people working with animations. To scrub, simply drag across the tabs, forward or backwards. You must not maxamize the document window or scrubbing won't work (this isn't a bug according to
Creature House). You can, however, enlarge the size of the document window by dragging on the edges of the document window and scrubbing will still work.

Mini Layer List: On the far right side of the document window is the Mini Layer List (hidden in the graphic above) which displays the layer structure of a document. The Mini Layer List is a compact version of the Object List. To toggle between showing and hiding the Mini Layer List choose
View > Show > Mini Layer List from the menu bar. Information on layers begins on page 108 of the user manual.

Status Bar: The status bar displays various information such as information related to the operation of the currently active tool, transformation values, steps for canceling tasks and memory usage (Mac only). You can hide the Status Bar if you need more screen space by choosing Window >
Status Bar from the menu bar.

Using Shortcuts

You may have noticed that some shortcuts in Expression 2 no longer work in Expression 3. This is because shortcuts were removed in order to let you define your own shortcuts. To set a shortcut, choose File > Preferences and choose Shortcuts from the drop down menu at the top of the
dialog box. A list of menu items appears in the order they appear on the Expression 3 menu bar. Scroll through the list and click on the item you want to set a shortcut for. If the item already has a shortcut assigned to it, a message to that effect will appear at the bottom of the dialog box. You can
modify existing shortcuts as well as set new ones. Customizing preference options begins on page 149 of your user manual. A list of menu items and their descriptions begins on page 155.

Working With Palettes

Many of Expression's features are available from palettes. These palettes show information about currently selected objects and allow you to change an objects attributes. A detailed list of all the palettes and the features they contain begins on page 37 of your user manual. Following is a brief
overview of how to use the sliders, meters and buttons common to all palettes. Other information specific palettes will be discussed throughout these lessons as we work with them.

Using Sliders: Many palettes have sliders that let you adjust an attribute's value. Press and hold down on a slider button for a tool tip displaying the current value of an attribute. As you drag a slider button to the left, to decrease a value, or to the right to increase a value, the tool tip remains
visible and updates to display the new value. If you can't get the precise value you need by dragging, double click on a slider and enter the value in the resulting dialog box. Some palettes have double sliders which can be moved individually, or together by Shift-dragging one of the sliders or by
dragging at the point where the two slider buttons meet. For more information on sliders, consult pages 38-39 of your user manual.

Using Meters: Meters display a numerical value in units which you can change in various ways. Drag any digit up or down to change it one unit at a time. For meters that support both positive and negative values, you can drag an empty digit space to the left of the value digit downwards for a
negative value, or drag a minus value digit upwards for a positive value. Alternatively, you can click on a meter, causing it to flash, and then type in a value using either the regular number keys or the number pad on your keyboard. You can move the decimal point by dragging it to the left or right.
Hold the Shift key and click on any digit to quickly reset a meter value to zero or the minumum value allowed. Like sliders, double click a meter and enter a value in the resulting dialog box. More information on meters appears on page 39 of the user manual.

Using Popup Buttons: Many palettes have buttons to access attributes or tools. Some palettes, such as the ToolBox, have popup buttons with a small slash in the lower right corner to indicate that more buttons reside underneath. Popup buttons display the current selection with an icon
unique to the selected tool or attribute. To access a button under the current one, press and hold down on the button until the other buttons are visible and scroll to the button of your choice, releasing the mouse when you reach your desired tool or attribute. More information on popup buttons, and
information on specific palette options, begins on page 39 of your user manual

With any palette, you can mouse over the various parts of the palette to display tool tips which identifies the item.

This covers the basics of the Expression 3 interface. When you are ready, proceed to lesson 1.

https://web.archive.org/web/20060112034256/http://www.studioe3.com/lessons/lesson1.htm
https://web.archive.org/web/20060112034256/http://www.studioe3.com/lessons/lesson1.htm


Lesson 1

Creating Simple Objects

In this lesson we'll start with a brief overview of vector graphics and what they are. After a short discussion on opening and saving documents in Expression 3, we'll move on to create simple objects using the shape tools and learn to apply strokes and fills to these objects. This lessons assumes
that you are either familiar with Expression 3's interface or that you have become familiar with the interface by reading the Expression 3 Interface Primer.

Reminder to Mac users: When the term Ctrl is used herein, substitute the Command key.

What are vector graphics?

Vector graphics are lines and curves defined as mathematical objects. Each path or shape that you create in Expression is an individual object which can be manipulated by editing the nodes attached to the path or shape. These objects can be moved, reshaped and resized without losing
quality. Graphics software which create vector graphics are referred to as vector-based or object-oriented drawing or illustration programs. In this lesson we well work with shapes. We'll discuss paths in a future lesson when we explore Expression drawing tools. Let's get busy and find out why
Expression, in my humble opinion, is the best drawing program on the market today.

Opening and Saving Documents

Expression is primarily a vector drawing program with bitmap capabilities. Vector graphics are opened in Expression using the File > Open item on the menu bar. Expression 3 supports all previous versions of Expression, Illustrator 9 and earlier (.ai files), EPS, WMF (windows only), and EMF
(windows only). Bitmap graphics, on the other hand, are imported into an opened Expression document using the File > Insert Bitmap option. Bitmap file formats that can be imported are PSD, TIFF, JPEG, GIF, PNG and BMP (windows only). You can also open recently opened documents using the
list of recently opened documents at the bottom of the File menu (Expression saves a list of 10 recently opened documents for easy access).

Expression 3 will only save vector graphic files in it's own .xpr file format. For crash recovery purposes, Expression periodically saves modified documents into rescue files. Thus, in the event of a crash, the next time you open Expression 3, it will open with a copy of the document you worked
on before the crash. When saving documents you have a choice of File > Save to save changes to an existing document, File > Save As for saving new documents or File > Save a Copy to save a previously saved document under a new file name. In the event that you've saved a document but
were unhappy with the changes you've made, you can revert back to the previously saved document using File > Revert to Saved. To save bitmap documents, use File > Save as Bitmap and choose from one of the available file formats.

If you haven't done so already, open a new document by choosing File > New from the menu bar or by using the Ctrl-N shortcut. Set your view preference. I like the 'actual size' option which you can choose by using the shortcut Home key on your keyboard or by choosing View > Actual
Size from the menu bar. You may prefer 'center view' in which case you would use the Shift-Home shortcut key. Expression 3 does not remember your preference so you'll have to do this each time you open a new document.

Let's take a quick look at the ToolBox palette before moving on to creating simple shapes.

The ToolBox

Expression sports an impressive arsenal of tools for creating vector objects. As you'd suspect, these tools live in the ToolBox which should be the top palette on the left side of the Expression interface unless you've move it to a new location. The tools you'll use most often are the Object Select tool
(first tool in the top row) and the Node tool (first tool in the bottom row). The Object Select tool allows you to move objects without disturbing the object's shape. The Node tool, which can also be used as an object selection tool, allows you to edit individual nodes on a path.

Hold your mouse pointer over any tool and a tool tip will appear to tell you the name of the tool, followed by the letter of the keyboard shortcut for that tool.

The tools you see on the ToolBox are only a few of the tools available. A slash in the corner of a tool button means that other tools are available below the displayed tool. As you can see from the graphic above, only the Hand, Zoom and Text tools occupy a space by themselves. To access
hidden tools, press on a tool button and hold momentarily until the drop down list of available tools appear, and then scroll down to the desired tool and release the mouse when you've reached the tool you want. For this lesson we will work primarily with the shape tools, all of which live under the
Rectangle tool (5th tool in the top row).

Creating Simple Shapes

In addition to a few new shape tools, Expression 3 now supports the ability to create shapes in precise dimensions. Clicking on the document window with any shape tool brings up that tool's specification box, unless you choose to disable this feature in Preferences (discussed a little later in this
lesson). Each specification box will display input boxes appropriate to the tool chosen. Figure 1 below shows the Rectangle Specification box.

Figure 1 - Rectangle Specification Box.

The X and Y Base Point, the first two input boxes in all specification boxes, will always contain the x and y coordinates of the location where you clicked in the document window. You can change these coordinates when you want the lower left corner of the shape to be in a different location than
where you clicked, assuming the 'Based at' specification in the last item in the specification box is set to 'Corner.' Otherwise, if the 'Based at' item is set to center, the x and y base point will be the center of the rectangle instead. Let's do an exercise so you fully understand this concept.

Exercise 1: Open a document if you haven't already done so. Go to File > Preferences and choose Tools from the drop down box at the top of the Preferences dialog box. If there is no check mark in the 7th item in the General Options
section labeled 'Obj. tools click shows input dialog,' check this item and press the OK button to close the dialog box.

Choose the Rectangle tool in the ToolBox by clicking on it. Set your rulers to inches using the drop down menu in the upper left corner of the document window where the rulers meet. Move your mouse over the document and notice the
lines that appear on the rulers and how they move as the mouse moves. Move the mouse until the lines on the rulers are as close to the 3 inch mark on the top ruler and the 6 inch mark on the left hand ruler and then click on the
document at that location. This will launch the Rectangle Specification box.

Notice the x and y coordinates and how they match the location of the point where you clicked on the document. Now look at the last item in the Rectangle Specification box and if 'Corner' is not the selected option, choose it from the drop
down box. Click on the OK button and a rectangle shape appears on the document. Notice that the lower left corner of the rectangle is placed at the 3 inch mark on the horizontal, and at the 6 inch mark on the vertical ruler. (Hover your
cursor over the lower left corner of the rectangle and notice the marks on the rulers to confirm this.) Click the Delete key on your keyboard to delete the rectangle and let's change the 'Based at' option to center.

Click on the document again at the same location to display the specification box and change the 'Based at' option to Center. Close the dialog box by clicking the OK button and notice that the center of the rectangle is now at the
coordinates you specified.

Go ahead and delete the rectangle if you'd like. We'll create a new one in the next exercise. For now, let's return to our discussion on the specification box options.

The next two input boxes on the specification box allow you to enter the width and height of an object, and each specification box will contain the default width and height dimensions for the particular shape tool you choose. All dimensions are stated according to your ruler settings. Because
your rulers are set to inches, the dimensions in your specification dialog box are stated in inches. Setting your rulers to points would cause the specification box to display values in points. You can enter different units of measure than what is displayed, however. For example, if your rulers are set to
inches, you can still type '400pt' as a value in a value text box and Expression will create the rectangle in points.

The specification boxes take a little getting used to. If you want to disable the specification boxes, go to Preferences > Tools and uncheck the item labeled 'Obj. tools click shows input dialog' in the General options section. Disabling the specification box feature simply means that you will
create objects by dragging with the shape tools instead of entering dimensions in the specification box. By the end of this lesson you'll know which method works best for you. Let's move on to examine the shape tools available to us.

From top to bottom, the shape tools include the Rectangle tool, the Ellipse tool, the Star tool and the Line tool. If you use the shape tools often, you'll want to learn the shortcut keys for selecting other tools and we'll practice this in the next exercise. Let's
examine each of the shape tools.

Rectangle Tool: The Rectangle tool is not new, but the ability to create rounded corner rectangles is. When you choose the Rectangle tool, a slider appears at the right end of the top row of the Toolbox which allows you to set the roundness of the corners
of a square or rectangle. Moving the slider all the way to the left end of the slider produces square corners. The corners become rounder as you move the slider to the right. Moving the slider all the way to the right will draw ovals and circles. You must,
however, choose your setting before creating the rectangle or square. The slider has no effect on the shape once the shape has been created. If you choose to use the specification box for this tool, you can enter the roundness specification in the input box
labeled, appropriately, 'Roundness.' Let's create another rectangle, this time with rounded corners. We'll practice moving and deselecting objects as well.

Exercise 2: With the Rectangle tool still active, move the slider on the right end of the ToolBox to the right until the tool tip says 20%. If you want exactly 20% but can't get that value by moving the slider, double click on the slider and
enter the value in the resulting dialog box. (There's almost always more than one way to do things in Expression.)

Place your mouse anywhere on the document and drag out a rectangle approximately 3 inches long and 1 inch deep. The rectangle now has rounded corners. Each rectangle you create will have 20% rounded corners until you change it.
Why didn't the specification box appear this time? If you simply click on the document with a shape tool, the specification box appears. Clicking and dragging creates the rectangle without the specification box.

The Shift key is a modifier key for the shape tools. Hold down the shift key and drag another rectangle shape. Notice that the only shape you can draw with the rectangle tool now is a square shape. No matter how hard you try, the top
and bottom sides of the shape will always be equal in measurement to the left and right sides of the shape when the Shift key is pressed before dragging.

Notice also that as you drag new shapes, previously drawn shapes become deselected. Only the last shape you create is active. To select a different object, choose the Object Select tool and click on another object to select it. Choose the
Rectangle tool and draw another rectangle and all other objects become deselected.

When you're learning the Expression program, it's to your advantage to learn the shortcut keys for choosing tools. Click the letter S key (lower case, not a capitol S) on your keyboard to select the Object Select tool and notice that a
'bounding box' appears around the last rectangle you created. (We will discuss the bounding box a little later in the lesson.) Click on the first rectangle you created, by clicking on edge of the rectangle, and it is now the active object. Click
on the edge of the first rectangle again and move the rectangle to a new location. Now click the letter R key, which is the shortcut key for the Rectangle tool, and the Rectangle tool is now the active tool. Watch the ToolBox as you
alternate between pressing the S and R shortcut keys to see how it tells you which tool is the active tool. Press the letter R key and drag a new rectangle.

Press the letter S key again for the Object Select tool. This time, click and drag from the upper left corner of the document window to the lower right corner and release the mouse to select all objects on the document window. Click on one
of the selected object and move it. Notice that all of the objects move because all of the objects are selected. Now click anywhere on the document window to deselect all objects. Unlike other drawing programs, you don't have to encase
an entire object to select it. With the Object Select tool, drag a marquee around only part of one of your rectangles to selected it.

Click the letter R key again for the Rectangle tool. Drag out another rectangle but this time, before releasing the mouse, hold down the Ctrl key and continue to drag. Holding down the Ctrl key before releasing the mouse allows you to
rotate the rectangle. Notice how the upper right corner of the rectangle is anchored, allowing rotation from that point. But what if you want a square, instead of a rectangle, and to rotate the square? You do what I call the finger dance.
First, before clicking on the document, hold down the Shift key and start to drag the square. When the square is the size you want, release the Shift key (but don't release the mouse) and hold down the Ctrl key and drag to rotate the
square, which again rotates from the upper left corner. If you find the finger dance too complicated, you can always use the specification box method and enter the degree of rotation in the Rotation box. (Entering a positive number in the
'Rotation' text box will rotate the rectangle or square counterclockwise. A negative number will rotate the rectangle or square clockwise.)

Now click away from the rectangle to deselect the shape. The object is deselected, unless you activated the specification box feature in Preferences in which case you'll get a specification box instead. If you choose to use the specification
box feature, you will benefit by remembering the shortcut key for the Object Select tool.

Whew! That was a lot of information for one exercise! If you think you'll use the shape tools often, spend some time practicing this exercise until you are comfortable with it before moving on. You have an entire week to complete this
lesson.

Ellipse Tool: With the Ellipse tool you have the ability to choose whether to draw an ellipse from the bounding box (the upper left hand corner of the object), or from the center. Choose the Ellipse and notice the two buttons at the end of the top row of the ToolBox, which was previous occupied
by the slider when the Rectangle tool was selected. The first button, labeled 'From Bounding Box' draws from the point at which you click on the document window to where you drag and release the mouse. The second button draws from the point at which you click outward from the center. If you
choose to use the specification box, these options are available as the last item in that box. Notice also the button below the two buttons just mentioned. This button gives you easy access to the Arc Modes which were previously only available from the Objects menu on the menu bar. We'll discuss
Arc Modes a little later. First, another exercise is in order and I promise not to overload you with information this time!

Exercise 2: If you just worked through the last exercise, either the Rectangle tool or the Object Select tool is active. If the Object Select tool is active, click the letter R key on your keyboard to switch back to the Rectangle tool. Look at
the Rectangle tool in the ToolBox and click the letter R key on your keyboard repeatedly and notice how this shortcut key cycles through the shape tools. Continue tapping the letter R key until you reach the circle icon which represents the
Ellipse tool.

With the Ellipse tool now active, click on the document and drag down and to the right to create a circle or oval shape. Press the letter S key for the Object Select tool, click on an edge of the circle and drag it to a new location and release
the mouse. Now click the letter R key again and notice that you are back to the Ellipse tool. Pressing the letter R key once returns you to the shape tool you were using before selecting another tool. Clicking on the letter R key a second
time will take you to the next shape tool in the list. Again, just continue to press the letter R shortcut key until you reach the tool you need. Pretty slick!

Click the first button on the right end of the ToolBox, labeled 'From Bounding Box' and drag down and to the right to create a circle shape. Notice that the circle draws from the upper left corner where you clicked and began to drag, and
that an x appears at that point until you release the mouse. Click the other button, labeled 'From Center' and drag another circle. This time your circle is drawn from the center. Regardless of the button you choose, holding the Shift key
before dragging creates a perfect circle. Without holding the Shift key, you can create oval shapes. You can't rotate a circle like you can a rectangle so holding the Ctrl key has no effect.

Arc modes are a little hard to explain. Basically, it's a feature that allows you to alter the shape of an oval or circle by cutting sections from them. If you click on the Arc mode button on the right end of the ToolBox and hold for a second you'll see three options; With Chord, Pie Mode and Open
Arc. These modes are only available to the Ellipse tool. Play along with me as I explain the different modes.

The 'With Chord' option allows you to create a straight edge along one side of a circle or oval shape. To create any of the Arc mode options requires the use of the Node tool. Below is an example of the With Chord option.

Figure 2 - With Chord option applied a to circle.

The 'With Chord' option is the default option for the Ellipse tool so I will assume that it is the active Mode for you. Hold your mouse over the Arc Mode tools and look at the tool tip. If it doesn't say 'With Chord,' hold and drag on the Arc Mode button and choose the top button is the resulting list
of Arc Mode buttons. With the Ellipse tool, drag out a circle shape. It doesn't have to be a perfectly round circle. Look closely at the circle and notice the red arrow at the top. This arrow is the only point from which you can create a straight edge. Click the letter A key on your keyboard to activate
the Node tool. With the Node tool, click the red arrow on the circle shape and drag along the edge of the circle, either clockwise or counter clockwise. Notice the line that follows your mouse as you drag. Release the mouse and the portion of the circle between the red arrow and point at which you
released the mouse disappears. This is the 'With Chord' option.

The 'Pie Mode' cuts pie shaped wedges from a circle. Press the R key to return to the Ellipse tool and drag another circle. Notice the line from the red circle to the center of the circle this time. Go back to the Node tool (letter A shortcut key), click on the red arrow at the top of the circle and
drag as you did before. If you drag clockwise, a pie shape piece is cut from the circle. If you drag counter clockwise, everything but the pie shape disappears. Below is an example of Pie Mode:

Figure 3 - Pie Mode option applied a to circle.

The 'Open Arc' option allows you to remove a section of the circle without altering the overall shape of the circle. Choose the Ellipse tool (by now you know which shortcut key you need), choose the 'Open Arc' option and once again drag out a circle shape. Use the letter A shortcut key (for the
Node tool) and drag from the red arrow either clockwise or counter clockwise. Again, if you drag clockwise, a section of the circle from the red arrow to the point at which you release the mouse disappears. Drag counter clockwise and only the section from the red arrow to the point at which you
released the mouse remains. Below is an example of Open Arc:

Figure 4 - Open Arc option applied a to circle.

The only real difference between the 'With Chord' option and the 'Open Arc' option is the 'Chord,' or the visible line, as you probably guessed (compare figures 2 and 4). Also, think of dragging in a counter clockwise direction as sort of a shortcut. If you drag counter clockwise, you are obtaining
the same shape as you would if you had dragged clockwise and released the mouse at the same point along the edge of the circle. Try this if it will help you to understand what's happening here. Create a circle and drag counter clockwise, releasing the mouse about 1/3 the overall distance of the
circle. Create another circle and drag clockwise, releasing the mouse at the same point. The resulting shapes are identical. This is true for all Arc Modes.

Before we move on to the Star tool, switch back to the Node tool (letter A shortcut key). Click and drag from the upper left corner to the lower right corner of the document window and release the mouse to select all objects. I had you do this to show you that the Node tool is also a selection
tool, in addition to a node editing tool, so when the Node tool is active you don't have to go after the Object Select tool (shortcut letter S key) to select objects.

Star Tool: The Star tool creates stars and polygon shapes. The Star tool gives you several setting options at the right end of the Toolbox. Using the shortcut key which you've memorized by now, switch to the Star tool to see the option buttons. The first button on the top row of the Toolbox is
the Break at Joints button (mislabeled 'Break at joins'). With this button depressed, a stroke is applied from point to point on a star shape instead of being stretched along the entire outside edge of the star. I know we haven't discussed strokes yet, but we will soon so bear with me. This button
must be pressed before dragging the shape; it will have no effect after the shape is created.

To the right of the Break at Joints button is the Number of Points meter. This lets you set the number of points for the star shape, but again you must set a value before creating the star. Star shapes can have from 3 to 99 points.

The sliders below the Break at Joints button and Number of Points meter are the Inner Depth/Star Variation sliders. The top slider determines the distance from the outer points of the star toward the center. With a low setting (moving the slider all the way to the left) you can create polygon
shapes. All the say to the right will give you spikes. In figure 5 below, the first star is drawn with a 20% setting in the top slider and the second star was drawn with an 80% setting:

Figure 5 - Star shape with 20% and 50% Inner Depth settings.

A 50% setting in the top slider, and a 0% setting in the bottom slider, is the setting for a perfect star shape.

The bottom slider is hard to describe. It gives you random inner depth shapes, meaning that the inner distance from each point in a star will be different. What in the world would you use this feature for, you might be asking. I suspect that Creature House had cartooning in mind when they
added this feature. In Figure 6 below, I have created a 15 point star with both sliders set at 50%, creating a cartoon speech balloon effect:

Figure 6 - Speech balloon effect.

Another, less obvious star tool feature is the twirl feature. Like the rectangle tool, holding down the Ctrl key at the end of a drag anchors the star and allows you to twirl the points. Try this: give the star tool a 15 point setting, with a 50% inner depth and 0% variation and drag a star shape
without releasing the mouse when you've reached the desired size. Press and hold the Ctrl key and drag the star shape in a clockwise direction. Notice that the points begin to twirl. You can twirl in either direction. Figure 7 is a 15 point star with a counter-clockwise twirl.

Figure 7 - Star twirled counter-clockwise.

Like the other shape tools, each settings available on the ToolBox for the Star tool is also available from the Star Specification box. The Rotation input box twirls a star counter-clockwise with a positive value and clockwise with a negative value.

Line Tool: The Line tool is straight forward and it too has a specification box. From the specification box you can set the beginning and ending x and y coordinates. To drag a line, simply click on the document where you want your line to begin, drag to the position where you want the line to
end, and release the mouse.

Notice I left you alone to experiment with the Star and Line tools. By now you know the shortcut keys and how to create shapes. Now, create a rectangle shape on your document and select it so we can give it some strokes and fills. An object must be selected before you can apply a stroke or
fill to it.

The Paint Style Palette

The Paint Style palette is where much of the fun lives. It houses all sorts of features, some of which are not readily apparent. Like all other palettes, running your mouse along various parts of the palette displays tool tips to identify each feature. Run your
mouse over the very top row of buttons and you will see that these buttons are "stroke" buttons. From left to right, the buttons are as follows:

No Stroke - Click this button if you don't want a stroke applied to your object.
PS Stroke: This is the plain stroke button. Nothing fancy, just a plain stroke.
Gradient Stroke: This is the button you'd choose to apply a gradient stroke.
SK Stroke: Let the fun begin! This is the Skeletal Stroke button.

Make sure your shape object is selected and click each of the stroke buttons to see how it affects the object. (Remember that an object must be selected before a stroke or fill can be applied to it.) Click on the No Stroke button and the stroke around your
object disappears. Try the Gradient button and notice that not only did the stroke change to a colored gradient, but that the color section of the Paint Style palette is replaced with a list of gradients. We'll discuss the color section shortly.

Under the stroke buttons you'll find the stroke width meter. This meter determines the width of your stroke for every type of stroke except the No Stroke attribute, obviously. There are several ways to change the stroke width value. Consult the meters
section of the Expression 3 Interface Primer for the various ways to change meter values and enter a value of 3 using the method you prefer. The new value is applied to your object and your shape is now surrounded by a 3 point stroke width.

Under the stroke buttons you'll find the Fill buttons. Run your mouse over these buttons and notice that once again the tool tips tell you the name of each button. By default, the No Fill button is the active fill attribute for a new document. The Fill buttons
are identified as follows:

No Fill: Click on this button if you don't want a fill applied to your object.
Solid Fill: Click this button to apply a solid color fill to your object.
Gradient Fill: Click this button to apply a gradient to your object.
Pattern Fill: Click this button to apply a pattern to your object.

With your object still selected, click on each of the Fill buttons to see how it affects the object. When you click on the Solid Fill button your object is filled with a solid black color. Notice that when you clicked on the Pattern Fill button that the color section of the Paint Style palette is replaced
with a list of patterns to choose from. Click on the pattern names in the pattern list to choose them and notice that the object updates immediately to reflect the new pattern. The Image Fill is similar to patterns and we'll discuss the difference in more detail in lesson 2. Let's take a look at the color
section of the Paint Style palette and see how to change the fill color of the selected object. Make sure the Solid Fill button is the active button in the fill section to display the color wheel in the color section. A button becomes 'active' when you click on it. You can tell when a button is active because
it appears depressed.

The color section of the Paint Style palette is where you change the color of both strokes and fills. The default color model in Expression is the HSL value picker which is the model displayed in the snapshot of the Paint Style palette at the beginning of this section. Other color models are
available and you access them using the small button to the left of the eye dropper icon in the bottom row of the Paint Style palette. If the HSL color model isn't currently the active color model, change it now.

The HSL color model displays a draggable triangle and color wheel much like the ones in other graphics programs. Place your mouse over the color wheel (to the right of the triangle) and your cursor changes to a hand cursor. At this point you can click and drag up or down on the wheel to
change colors. Notice when you drag on the color wheel how the colors in the triangle change also. The triangle is the area where you select the exact color you want by clicking or dragging within it. Let's change the color of the selected object in the document.

If your object is not currently selected, select it with the Object Select tool. Make sure that the Solid Fill button is active. Drag down on the color wheel until the colors in the triangle display various shades of green. Click inside the triangle and watch how the fill color of your circle changes to
your newly selected color. The triangle is draggable. Click and drag on the triangle and watch how the colors in your object change to the new color after you release your mouse. Notice also the oblong box to the right of the color wheel and that as you drag on the triangle, the colors are
immediately reflected in the box. This rectangle is referred to as the Color Box.

I should mention an important note about selecting objects with or without fills at this point. Earlier I mentioned that to select an object with the Object Select tool, you had you click on the edge of the object to move it. This was because the objects we worked with at that point only had a
stroke applied to it. When a shape, or any other object for that matter, has only a stroke applied to it, the center of the shape is considered empty and, consequently, has nothing within the shape to 'grab onto' and drag. When the object is filled with any of the fill attributes, you can click anywhere
within the object to move it.

Now we know how to change fill colors but what if we want to change the color of the stroke? A common problem people have with changing colors is knowing when a color will be applied to the stroke and when it will be applied to the fill. Let's take a closer look at the Paint Style palette and
see how to make that determination.

Notice in the snapshot below, the Stroke Preview box to the left of the stroke buttons and the Fill Preview box to the left of the fill buttons:

Figure 8 - Paint Style palette with fill option active.

In the image above, the Fill Preview appears depressed and has a checkered background. This means that the fill option is the active option and any color change will apply to the fill. To change the color of the stroke, either click on the Stroke Preview, or on either the Solid Stroke or Skeletal
Stroke button, depending on which type of stroke you're using. Try it now. With your object still selected, click on the Stroke Preview and notice that the color section changes to black, the current color applied to the stroke on the object. Choose another color and notice that this time the color
change is applied to the stroke instead of the fill. Well great. Mystery solved. Let's move on to find out what the meter below the fill buttons is for.

Notice the little black button on the Paint Style palette to the left of the meter under the row of Fill buttons. Mousing over this button reveals the tool tip 'Choose Fringe Texture.' This is the Soft Edge/Emboss button. To the right of this button is the Soft Edge/Emboss meter with a value of zero.
Entering a positive number in this meter applies a soft edge to an object. Entering a negative number applies an Emboss effect. Let's experiment with the Soft Edge/Emboss button in another exercise.

Exercise 3: You should have a rectangle object on your document filled with a green color and a black stroke. Enter a positive value of 16 in the Soft Edge/Emboss meter and notice how the rectangle object now has a blurred appearance
which extends beyond the edges of the rectangle, like this:

Now enter a negative value of -16 in the Soft Edge/Emboss meter and notice how the rectangle object now appears beveled.

Another thing that happens when we type in a negative number is that the Soft Edge/Emboss button turns blue, indicating that the active effect for the currently selected object is the embossed effect.

Notice that only the fill is embossed, not the stroke. The stroke isn't very attractive anyway so let's remove it by clicking the No Stroke button:

The red outline you see in the image above is the 'path' which is what a stroke attaches to. A path is only visible on a selected object. Deselect the object to see that the path is no longer visible. Select the rectangle again and enter a
positive value in the Soft Edge/Emboss meter and let's see what hidden treasures lie beneath the Soft Edge/Emboss button.

With a positive value in the Soft Edge/Emboss meter, you have the ability to add a fringed edge to an object instead of a soft edge and you do this by clicking on the little black button displaying the 'Choose Fringe Texture' tool tip. Click on it now to get a new dialog box with a list of fringed
edges to choose from. This dialog box is displayed below:

Exercise 4: With the rectangle object selected, click on the Soft Edge/Emboss button and choose a fringe by clicking on either the name of the fringe file of the graphic display of the file to the left of the fringe file name. I chose the
'bumpy,tif' file. In the Fringe Options drop down box, choose the 'Repeating' option and click the OK button. Mine looks like this:

Click the Soft Edge/Emboss button again you'll see that the current fringe on your selected object is highlighted. Leave the current fringe but change the Fringe Option to 'Stretch to fit' and click the OK button to dismiss the dialog box.
Notice that the fringe now stretches around the object instead of repeating:

To return to a soft edge instead of a fringe, click the Soft Edge/Emboss button again and choose the 'No Fringe' item at the top of the list and, once again, click the OK button.

Fringed edges are graphic files stored in Expression 3/Textures/Fringes sub-folder on your hard drive. You can add more fringed edges to Expression 3 by simply creating more graphic files and dropping them in this sub-folder. You might want to open some of the files already in this sub-folder
for ideas on creating new images. This is a subject not covered in this beginning class.

When you enter a negative value in the Soft Edge/Emboss meter, clicking on the Soft Edge/Emboss button (which is now blue) reveals a list of Reflection maps to choose from. This calls for another exercise.

Exercise 5: Enter a negative value in the Soft Edge/Emboss meter once more. As before, the button changed to a blue button and if you mouse over it when it's in the Emboss state, you will see a new tool tip displaying the message
'Choose Reflection Map.' Click on this button and you'll get a dialog box similar to the fringed edge dialog box only this time you get a list of Reflection maps and an option to change the angle at which the reflection map is applied. Choose
a reflection map from the list and click the OK button to dismiss the dialog box. I chose the 'handpainted.tif' reflection map:

Notice that the Soft Edge/Emboss button is now a silver ball instead of a blue button. When you click on objects, the Soft Edge/Emboss button serves to tell you type of Soft Edge/Emboss fill is applied to the object. To change reflection
maps, click the Soft Edge/Emboss button and choose a different reflection map. Experiment with entering values in the 'Reflection map rotation' box. To remove a reflection map and return to a simple emboss, click the Soft Edge/Emboss
again and choose the 'No Map' item at the top of the list and click the OK button.

Reflection maps are graphic files stored in Expression 3/Images/Envmaps sub-folder on your hard drive. You can add more reflection maps by simply creating more graphic files and dropping them in this sub-folder. Sources for additional reflection maps include Environment Maps by Ann-S-
Thesia and Sara's Reflection Maps. You can, of course, create your own reflection maps but this is an advanced subject not covered in this beginning Expression 3 course. However, Sara has written an excellent Reflection Map Tutorial and a tutorial for making your own reflection maps that you'll
undoubtedly want to explore if this subject is of interest to you.

A final word on reflection maps: At times you will notice that the edges of an object with a reflection map applied with appear to have jagged edges. Correcting this flaw would have a dramatic effect on the performance of the program so Creature House suggests that you rasterize the object to
eliminate the jagged edges. We will discuss rasterizing objects in another lesson.

Transparency: There's a double slider between the Stroke Preview and Fill Preview that allows you to change the transparency of strokes and fills. Moving the bottom slider toward the left affects the transparency of a fill and moving the top slider to the left affects the transparency of a
stroke. With your rectangle object selected, use the shortcut key combination Ctrl-D to make a copy of the object. The copy should overlap the original. Move the bottom transparency slider to approximately 50% and notice that the top, active object now allows the object under it show through:

Click on the PS Stroke button to give the top object a stroke. Move the top slider to the left, about 50%, and notice that the stroke now become transparent as well:

To move both transparency sliders at the some time (assuming they are both at 50%) click in the center where the two slider buttons meet and move them all the way to the right to remove the transparency. Let's take a look at textures.

Textures: See the button to the right of the transparency sliders? (It's faint so look close.) Click that button for a list of textures. Choose a texture from the list by clicking on it and then press the OK button to dismiss the texture dialog box and apply the texture to the active rectangle object.
Notice that texture is applied to both the stroke and fill attributes of the object.

Once you apply a texture to an object, the name of the texture is listed to the left of the texture button on the Paint Style palette. If you decide to change the texture, click on the texture name and choose another texture. With textures, there is no item in the list to remove a texture like there
in the Fringed Edge and Reflection Map dialog boxes. To remove a texture, click the texture button.

Notice, in the image above, that the top rectangle is transparent once the texture is applied. In the texture dialog box you have a choice of choosing opaque or transparent. You also have the option to scale the texture by choosing a predefined value in the 'Texture Scaling' drop down box or by
entering a custom value. Below is my rectangle with texture scaling at 33% and texture mode set to opaque:

What if you want texture on the fill but not on the stroke? My solution is to do this:

Exercise 6: First, delete the bottom rectangle; we don't need it any more. Make a copy of the remaining rectangle, which should be the rectangle with the texture applied. On the copy, click the Texture button to remove the texture and
click the Fill button to remove the fill. On the original rectangle, click the No Stroke button to remove the stroke. Finally, position the copy over the original rectangle.

With the copy still selected, adjust the stroke size using the Stroke Width meter on the Paint Style palette. If you want to change the color, texture or emboss of the original rectangle, select the original with either the Node tool or the
Object select tool and make the adjustments. Here's mine:

My rectangle uses the Paper 4.bmp texture file with 'Texture Scaling' at 200% and texture 'Mode' set to opaque.

If you have problems aligning the two rectangles, do this: select both rectangles by dragging a marquee that captures at least part of both rectangle objects. Choose Arrange > Align > V. Centers and then Arrange > Align > H.
Centers from the menu bar.

Textures are graphic files stored in the Expression 3/Textures sub-folder on your hard drive. To add more texture, simply place other texture graphics in this sub-directory and they appear immediately in the texture list.

There's still more to learn about the Paint Style palette and we will cover gradients, patterns and image fills in lesson 2 as we work with the Text tool. Until then, we will take a quick look at the bounding box and then I'll give you a homework assignment. Leave your rectangle shapes on the
document as we discuss the bounding box.

Bounding Box

I mentioned early on that when you click on an object, the object becomes selected and is surrounded by a bounding box. The bounding box allows you to resize and rotate objects. Our rectangles might make great web buttons, but not at the size they are now. Select both rectangles and
notice the bounding box that surrounds them. Below are my rectangle shapes displaying the bounding box:

Notice the triangles in each corner of the bounding box. These are the Resize Handles. As your mouse pointer moves over a Resize Handle, the pointer changes to a pointer with double pointing arrows to indicate that clicking and dragging the handle will resize the object. How objects resize
depends on your setting in Preferences. Choose File > Preferences from the menu bar and select 'Tools' in the drop down box at the top of the Preferences dialog box. In the center of the General Options section is an item labeled "Resize Handles: Scale from center." If there is a check mark in
that box, remove it by clicking on the check box. Click the OK button to dismiss the dialog box.

On your document, with both rectangles selected, click on the resize handle in the upper right hand corner and drag it up and to the right. Nothing appears to happen and you drag but when you release the mouse, the bounding box become larger and the rectangles expand to fill the new size
of the bounding box. Choose Edit > Undo Scale and let's expand the rectangles proportionately in all directions.

The Shift key is also a modifier key for the bounding box. Holding the Shift key and you drag a resize handle causes the bounding box to expand proportionately in all directions. Let's try it. Hold down the Shift key and drag the same resize handle in the same direction as before. Well great, but
we want our rectangle smaller, not larger so choose Edit > Undo Scale again and let's make our rectangles smaller. Hold down the Shift key and drag the same resize handle but this time drag it down and to the left, toward the inside of the rectangle shapes and releasing the mouse when you
mouse pointer is in about the center of the rectangle shapes. This is a much nicer size for, say, a web page button:

We removed the check mark in the Preferences dialog box that caused the resize handles to not resize from the center. Placing a checkmark in that box will cause an object to scale proportionately in two direction from the center of the object. For example, if you drag the upper right Resize
Handle upwards, both the top and bottom of the bounding box will scale proportionately from the center of the object. Try this yourself and determine which method you prefer.

One final note on the Resize Handles. When I mentioned that as you drag a Resize Handle, nothing appears to happen. Normally, when you drag a Resize Handle you should see an outline of the object to show you the position of the object before you release the mouse. On my system (WinXP)
I sometimes get the outline, and sometimes I don't. What you get may depend on your operating system. I suspect this is a bug and it has been reported to Creature House.

The little squiggles on each of the four sides of the bounding box are the Rotation Handles. As your mouse pointer moves over a Rotation Handle, the pointer changes to a pointer with rotating double pointing arrows to indicate that clicking and dragging the rotation handle will rotate the
object. With both of the rectangle shapes selected, drag on the rotation handle on the right and drag downward. Again, nothing appears to happen until you release the mouse and then the objects rotate, like this:

Choose Edit > Undo Rotate and drag the same resize handle upward this time. Any rotation handle will rotate an object either clockwise or counter clockwise, depending on the direction you drag the resize handle.

Homework Assignment

You didn't really think I was going to let you leave class without a homework assignment, did you? Your assignment is to practice creating simple objects using the methods outlined in this lesson and apply strokes and fills to the objects until you are comfortable with the Paint Style palette and
selecting and deselecting objects. These are areas you'll want to master if you intend to use Expression 3 as a drawing tool. The remainder of these lessons will assume that you have learned the techniques in this lesson. When, in a future lesson, I say to apply a green color fill, you'll know how to
do that, right? Good deal! See you next week.

All material presented in this course is ©2003-2005 Annie Ford
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Lesson 2

Creating Text Objects

In this lesson we will learn about text objects which are very similar to shape objects. As we progress through the lesson we will learn to use the Text tool to make objects other than text, such as patterns.

I have chosen not to go into detail about the Font palette and all of its features because the features are not only self-explanatory, they work as they do in any other graphics programs. I feel that there is so much material to cover in six short weeks, that you'd be happier learning features that
are unique to Expression instead of covering material you undoubtedly already know.

Creating Text Objects

Launch Expression 3 and open a new document if you haven't already. Open the Font palette by pressing the F5 key on your keyboard or by choosing Window > Font from the menu bar. If the Font palette doesn't dock itself with the other palettes on the left side of the interface, drag it there
by dragging the palette's title bar. Otherwise, drag the Font palette to a location that is convenient to you.

Press the lowercase letter 't' key on your keyboard or click on the Text tool on the Toolbox. At this point you can click anywhere on the document window and begin typing text. Click anywhere on the document window and notice the changes to your Paint Style palette. Notice that the No Stroke
button and the Fill button are both active. This is how Expression 3 creates text objects. Before you type anything, locate the "Point Size" meter on the Font palette and change the value to 66 points. You'll notice see the cursor enlarge on the document window to reflect the larger size type. Now
type your first name.

At this point, your name is plain text which can be edited as in a word processing program or other graphics program. To edit the text, place your cursor before the first letter in your name and drag it to the right until all the letters in your name are highlighted. (You can also drag from right to
left.) Change the Point Size meter again and notice that when the new value is set, the text on your document changes to reflect the new point size. Once the text is highlighted, you can change mistakes by typing new text to replace the old.

As with shape objects, you can move text with the Object Select tool. Click on this tool (don't use the shortcut key or you'll add the letter 's' to the end of the text) and notice that the text is now surrounded by the bounding box. Click anywhere on the text to move it. When you're ready to
move on, delete the text and activate the Ellipse tool and we'll create text on a path.

Text on a Path

First, make sure that the 'With Chord' option is the active option on the ToolBox for the Ellipse tool. If it isn't, your text will not follow a path correctly. With the Ellipse tool, drag out an oval shape, wider than it is tall. You will remember that the Fill button was activated by our Text tool so click
on the No Fill button to remove the black fill from the oval. You should have something that looks like this:

Figure 1 - A path with which to attach text.

Select the Text tool (lower case letter t) and move it toward the oval until the line on the text cursor changes to a squiggly line, like this:

Figure 2 - The text cursor as it approaches the oval.

Now type your full name and notice how the text follows the path. If you make a mistake, press the delete key repeatedly until you back up past the mistake and begin typing again. Here's the text I typed, and as you can see, I did a poor job of judging where my text should begin.

Figure 3 - Badly placed text on a path.

To correct mistakes like this, move the text cursor to the beginning of the text until the cursor changes to the text cursor with solid, double pointing arrows on both sides and then drag in the direction in which you want to move the text. You'll notice that an outline of the text appears as you
drag, like this:

Figure 4 - Moving badly placed text on a path.

When the outlined text is in a position that you're happy with, release the mouse and your text will replace the outline, like this:

Figure 5 - Repositioned text on a path.

You can use this same method to move the text to the inside of the path by dragging downward instead of left or right, like this:

Figure 6 - Repositioned text on a path.

You can even make text upside down on the inside of the path by first dragging down and then sliding the text in either direction until it is upside down. Not sure why you'd want to do this, but it can be done.

One thing to keep in mind when you're creating text, including text on a path, is that you can't use a shortcut key to switch tools when you're done typing. Doing so will only add a letter to the end of the text. Once you're done typing, you need to do something to tell Expression 3 that you're
done typing. One option is to click on a selection tool (the Object Select or Node tools) and move the object. Another option is to hold down the Ctrl key, which temporarily switches the tool you're using to a selection cursor. This allows you to move the object and return you to the tool you were
using before you held down the Ctrl key. You can also hold down the Ctrl key, move the object slightly and then use a shortcut key to choose another tool. Moving the object tells Expression you're done typing.

Keep in mind also that when you select the text object with a selection tool, the path it is attached to seems to disappear. It's still there and you can select it by simply dragging with a selection tool to enclose both the text and the path it's attached to.

Another method for creating text on a path is to type text, create a path to attach it to, select both objects and then choose Objects > Text on Path > Attach Text. To release text on a path, regardless of the method you used to create it, select both objects and choose Objects > Text on
Path > Release Text.

Text within a Path

A similar method is used to create text within a path, referred to in Expression as 'Text Area' text. First, create a shape object as you did before. Move your cursor toward the object until the cursor changes to the text cursor with a squiggly line, as before. This time, hold down the Shift key,
which turns your cursor into a text cursor enclosed by a circle, and click. This places the text cursor within the shape, rather than on the path itself, so that when you type, the text stays within the shape. You can also create the shape, create the text separately, choose both objects and choose
Objects > Text on Path > Attach Text Area from the menu bar. To release text from the object, select the text and the object it is attached to and choose Objects > Text on Path > Release Text. Once text is inside the object, you can edit the text and apply all the attributes available on the
Font palette. I'll let you play with this feature on your own and when you're ready, read on and we'll explore still more things you can do with text.

Converting Text Objects to Paths

In Expression 3, there are two types of objects; path objects and simple objects. A path object is something you create with one of the drawing tools, such as the Freehand or B-Spline tools. Nodes appear at various points along the path which allow you to alter the path's shape by moving the
nodes. Simple objects are objects without nodes, such as shape and text objects. Simple objects can be stroked and filled just like any other object but they can not be altered in shape like objects with nodes, except to resize and rotate the shapes with the bounding box. Fortunately, simple objects
can be converted to path objects so that more alterations can be done to them.

When you create a text object, all of the text characters are grouped together to form one object. Below is an example of a simple text object:

Figure 7 - A simple text object

If you apply attributes to a text object, such as a stroke and/or a fill, the stroke and fill will apply to all of the text characters in the object. You cannot, for example, apply one stroke to the first letter and a different stroke to other letters. If we take the text object and choose Objects >
Convert to Path from the menu bar, look what happens:

Figure 8 - A simple text object converted to a path.

All those little red dots around the text are called nodes. Each node can be pulled and stretched to alter the shape of the text characters with the Node tool. (This is what sets the Node tool apart from the Object Select tool.) The text characters are still grouped together, however. To ungroup
them, choose Arrange > Ungroup from the menu bar. Click away from the text object to deselect all characters (or right-click on the document window and choose 'Deselect All' from the context menu) and you are now able to choose one or more text characters individually.

Let's do a quick exercise and practice what we just learned.

Exercise 1: Choose the Text tool and type your first name in a medium sized text, approximately 86 points. From the menu bar choose Object > Convert to Path and then Arrange > Ungroup. Expression knows that you are through
typing now so select the Object Select tool using the shortcut key and click away from the text to deselect all characters. Click on each letter and notice that not only is each letter full of nodes, but that each letter is surrounded by its own
bounding box. Click on the first letter in your name and use one of the Resize Handles to enlarge it. (Move it slightly if it obstructs the other letters.) Apply a pattern and notice that the pattern was only applied to this letter individually
rather than all of the letters. Choose the Skeletal Stroke button and enter a value of 2 points in the Stroke Width meter. If all went well, you should have something like this:

Figure 9 - A text object converted to a path and altered.

Before we move on to create patterns with our newly gained knowledge of the Text tool, I will cover patterns in general and how patterns differ from image fills.

Image Fills v. Patterns

Image Fills: Image fills are bitmap graphic files located in the Expression 3/Images sub-folder on your hard drive. Files located in this sub-folder do not automatically appear in the Image List when the Image Fill button is active. You must add an image to the list using the + button at the
bottom of the Image List palette. When an Image Fill is applied to an object, you can adjust the fill with the Transform Fill tool (Shift-X) which is located under the Object Select tool on the ToolBox.

Click on the first letter in your name from the previous exercise and apply an Image Fill to it by clicking the Image Fill button on the PaintStyle palette and then clicking on an item in the Image Fill List that replaces the color palette. Choose the Transform Fill button on the ToolBox. Click on the
upper right Resize Handle on the bounding box surrounding the letter and drag away from the letter as if you're attempting to enlarge it. Notice how the letter appears to enlarge but goes back to normal size when you release the handle. This expands the image fill, not the letter itself. Click on the
same resize handle and drag toward the letter this time. This shrinks the image fill. This means that you don't necessarily need Image Fills to be seamless. You can eliminate any seams by adjusting it's size with the Transform Fill tool. To rotate an Image Fill, drag the rotation handles on the
bounding box with the Transform Fill tool. To move the Image Fill within the object, rather than enlarge or shrink it, drag within the object with the Transform Fill tool. The Transform Fill tool only works on text objects that have been converted to paths (Creature House says that this is a bug but it
has yet to be fixed).

An excellent source for Image Fills can be found at the Auto FX web site, but you'll need to register to download the files. To delete an Image Fill from the list, remove the image file from the sub-directory. While a minus button appears on the Paint Style palette, suggesting that you can delete
files this way, my button doesn't work. If your button works, deleting an Image Fill this way only deletes the item from the list, not the actual file in the sub-directory.

Patterns: Patterns differ from Image Fills in that they are made up of vector objects rather than bitmap images. When you click on the Pattern Fill button a list of patterns appears below the Fill buttons on the Paint Style palette. As you can see, the list is sparse. Most of the patterns are hatch
patterns which were originally used to create hatch effects in Expression 1. While the hatch feature was eliminated in Expression 2 and 3, the patterns remain.

The Transform Fill tool works the same on patterns as it does with an Image Fill. Patterns have the added feature of transforming the pattern when an object is transformed, or not. We'll examine this added feature shortly.

Defining Patterns

Let's create a pattern to see just how easy it is. In the process we'll learn about another tool and palette; the Rotation tool and the Transformation palette.

Exercise 2: Clear away everything on your document window, or open a new document to work in. From the menu bar, choose View > Show > Grid. This places a grid on your document window and grid spacing is set according to the
unit of measure set on the rulers (e.g., if your rulers are set to inches, your grid will display in inches as well).

Choose the Ellipse tool and activate the 'From Center' option button at the right end of the top row on the ToolBox. Click on a grid intersection and drag out a circle shape; the size doesn't matter. Give it a plain, 6 point yellow stroke and
no fill. Now choose the Text tool, click on the document window above the circle, type an exclamation point (!) and give it a yellow fill color. You should have something like the following:

Figure 10 - The beginning of a 'sun' pattern.

With the exclamation point still selected, choose the Rotation tool on the ToolBox (6th tool in the bottom row with an icon that looks like the letter G) by clicking on the tool or by using the Shift-R shortcut key. Notice that a + sign appears
in the center of the exclamation point. This is referred to as the 'point of rotation.' The center of an object is the default location for the point of rotation but you can change this point as we will do now. With the Rotation tool still active,
click in the center of the circle object where the grid intersections meet, like this:

Figure 11 - The beginning of a 'sun' pattern.

This places the 'point of rotation' for the active object (the explamation point in our case) in a new location. (Each time you click with the Rotation tool you establish a new point of rotation.) Now open your Transformation palette by
choosing Window > Transformation from the menu bar, or by using the F9 shortcut key. A screen shot of the Transformation palette appears on the left.

Hover over the meters on the Transformation palette to find the Rotation Angle meter and set it to 30 degrees, as it is in the screen shot above. Click the second button from the right on the bottom row of the Transformation palette
eleven (11) times. (The button will say 'Apply to Duplicate' when you hover over it.) What you just did was create 11 more exclamation points which rotated 30% around the point of rotation. You should now have a 'sun' shape which looks
something like this:

Figure 12 - Completed sun for a pattern fill.

This sun is a little big for a pattern so let's shrink it down to size. Choose the Object Select tool and drag a marquee around all the objects. Choose Arrange > Group from the menu bar. This groups all the objects together so they act as
one object. Hold down the Shift key while you click and drag on a Resize Handle, dragging toward the grouped object so that the objects shrink to the size of the pattern you want to make, and release the mouse. Here's mine:

Figure 13 - Completed sun for a pattern fill, reduced in size.

Now we're ready to make a pattern. Patterns are 'defined' with the Pattern Definition tool, which lives under the Stroke Definition tool (last button in the top row of the Toolbox). Choose this tool and drag a marquee around your sun shape
and release the mouse. You'll notice a large, gray box surrounding the sun object which contains lots of little gray suns. This is the Pattern Definition box and it serves to show you what your pattern will look when it is defined. If you don't
like the way the pattern lines up, click the Delete button on your keyboard to dismiss the definition box and try again. When you're happy with the pattern, click the button to the right of the Magnification button in the lower left hand
corner of the document window which, when moused over, displays the 'Define Pattern' tool tip. Enter a name for your new pattern in the resulting dialog box and click on the OK button. Your pattern is now added to the list of patterns in
the patterns list. If the Pattern Definition box does not disappear after you defined the pattern, click the Delete button to dismiss it.

Create a shape object and choose the Pattern Fill button. Scroll through the list of patterns until you find your new pattern and click on the pattern's name to apply it to the object. How does it look? Here's mine:

Figure 14 - Sun pattern.

Using Dingbat Fonts: A dingbat font (a picture font as opposed to an alphabet type font) can also be used as an object or objects from which to create patterns. An excellent source of dingbat fonts is The Dingbat Pages. I'll use a shareware font called Oregon (Oregon Dingbats.ttf) to
demonstrate a method for defining patterns which I call 'pattern wrapping.' Below is a screen shot of "storks" created from the capital letter G with a solid blue color fill and a darker blue, 2 point wide plain stroke.

Figure 15 - 'Storks' from the Oregon font.

Pattern Wrapping

When we created the sun shape, we dragged the Pattern Definition tool around the entire shape to create a pattern. The resulting pattern was orderly rows of sun shapes (See Figure 14 above). Sometimes we want to create a more random appearance and to have the pattern tile seamlessly.
We can achieve this effect by dragging the Pattern Definition tool around only part of the objects used to make up the pattern. Any part of an object outside of the area enclosed by the Pattern Definition tool will wrap around to the opposite side of the pattern. I'll demonstrate, but first let's take
another look at the pattern definition box:

Figure 16 - Orderly stork pattern.

The white square in the center of the Pattern Definition box displays the area enclosed by the Pattern Definition tool and the gray area around it (the preview area) displays what the pattern will look like. In the example above we can identify each object in the pattern because each object is
lined up in neat little rows. This time I will enclose only part of the object and the result is shown below:

Figure 17 - Orderly stork pattern.

From the objects in the center of the definition box, you can see that I've cut off almost all of the head from the top stork and enclosed only parts of the bodies of the two bottom storks with the Pattern Definition tool. Yet the preview area suggests that all the parts are included in the pattern.
When the resulting pattern is applied to an object, you'll see that all the parts are still there:

Figure 18 - A more random appearing stork pattern.

As you can see, it's much harder to tell where one object in the pattern ends and another begins. Experiment with pattern wrapping but be forewarned: pattern making can become addicting. Try creating more than one object and enclosing all of the objects with the Pattern Definition tool.
Then use the same objects but enclose only parts of the objects. You might even try creating one object and enclosing only part of it. Here's a chestnut design, and resulting pattern, when I enclosed only the bottom part of the chestnut and let the scroll design at the top wrap around:

Figure 19 - Chestnut design and resulting pattern.

The pattern still appears rather linear. The way to fix this is by rotating the Pattern Definition box. To do this, drag around all or part of one or more objects and release the mouse to display the Pattern Definition box. Choose the Object Select tool and the definition box is surrounded by a
bounding box. With the Object Select tool, rotate the definition box using one of the bounding box Rotation Handles. The small object display box in the center will show you your rotation angle. Release the mouse and the pattern in the gray area of the definition box will update to display the new
pattern's appearance, like this:

Figure 20 - Rotating the Pattern Definition box.

Notice that the object itself was not transformed. Only the definition box was transformed. Below is the resulting pattern:

Figure 21 - Rotating the Pattern Definition box results.

Even our orderly sun pattern becomes more interesting when the definition box is rotated. Compare the following pattern with the one in Figure 14 above:

Figure 22 - Sun pattern skewed.

As you can see, making patterns is easy and fun. Let's do another exercise and see how easy it is to edit a pattern.

Exercise 3: Choose the Pattern Fill button so your sun pattern is visible in the Pattern Preview window. The Pattern Preview, remember, is to the left of the Fill buttons on the PaintStyle palette. Double click on the Pattern Preview and
your pattern will open in a Pattern Definition box. (Alternatively, click the Edit button at the bottom of the Patterns List). With the Object Select tool, click on the circle object and change the stroke color. (We had originally grouped these
objects before defining the pattern but they become ungrouped in the Pattern Definition box.) The Pattern Definition box seemed to disappear when you selected the circle, leaving only an outline behind. Don't worry, we'll get it back.
Make any other modifications you want to the objects in the pattern.

When you're happy with your color choice(s), drag a marquee over the outline of the definition box (you don't need to enclose the entire box, just part of it) and the definition box re-appears. Click the Define Pattern button. The name you
originally gave this pattern will appear in the text box. Either click the OK button to write over the original pattern or give the pattern a new name and click the OK button. Delete the definition box if it remains. (We'll learn how to change
the pattern definition box behavior soon.) So now you know that when you make a pattern you don't need to make it in all the colors you might want; just edit the pattern as needed.

Now let's apply the sun pattern to an object. Choose any shape tool and create a shape. Click the Pattern Fill button and choose your new pattern from the patterns list. Using a Resize Handle, enlarge the shape and look at what happens to the pattern. This is an area where you have a choice
as to how patterns behave when an object is transformed. You make these changes in File > Preferences. If, when you enlarged the object the pattern enlarged as well, you have a check mark in the 'Transform Patterns' item in the General section of the Preferences dialog box. Unchecking this
item will cause the pattern to maintain it's shape when the object it fills is transformed. And remember, you also have the option to use the Transform Fill tool which, as I mentioned earlier, works as it does for Image Fills.

If you've examined the patterns in the patterns list, you might have noticed that they don't have background colors. In the image below, I've create a solid filled object and placed a pattern filled object on top of it. Notice how the bottom rectangle is visible due to the lack of a background color
in the pattern:

Figure 23 - Transparent pattern fill.

You'd think that all you'd have to do is make a solid fill background and define it right along with the other pattern objects. Unfortunately, a bug in the program prevents this. The only work-around is to create two objects, give the bottom one a solid fill color, the top one a pattern, and line
them up so they look like one object. This isn't really such a bad workaround, however, as it makes it possible to change the background color without having to redefine the entire pattern.

One final observation about patterns: Unlike Image Fills, patterns are stored in a text file (Expression 3/patterns.txt) so you can't add or delete patterns by dropping files in a sub-directory. A delete button appears at the bottom of the Patterns List but deleting a pattern will delete it for all
times. You can't get it back. If you intend to create a lot of patterns, consider creating a separate file (an .xpr file) and create shapes filled with the patterns. Save the file and you can then delete the patterns from the list. When you want a pattern, open the patterns.xpr file (or whatever you
choose to name the file). Once you open the patterns.xpr file, the patterns will appear in the patterns list but only the patterns you actually use will remain in the list. If you own a copy of Expression 1, you will find 4 files of patterns which you can use this way.

Let's do one more exercise. This exercise will give you another opportunity to work with the Rotation tool and the Transformation palette. Ok, ready?

Exercise 4: First, scroll through the list of fonts in your Font palette and find one you like. A script font, a fun font, whatever you like. I'm using a font from the Font Garden called 'Mad Font' which you can download for the PC (top font in
the list). Type a letter. I'm using the lowercase letter n. Either leave the font as it is, or rotate it. I'm rotating mine slightly so that it looks like this:

Figure 24 - The letter N rotated for a pattern.

You can give your font a color at this point, if you'd like to. Choose the Rotation tool and click on the point from which you want to rotate the letter. My rotation point is here:

Figure 25 - The letter n rotation point.

Set the Rotation Angle meter to 90% on the Transformation palette and click on the Apply to Duplicate button 3 times. This is my result:

Figure 26 - A design from the letter n.

Remember, when you create objects, only the last object you create is selected. At this point you might want to select all of the objects and group them together so your design won't come apart if you accidentally move one of the objects.
Want to know how to select one object in a group of objects without selecting them all? The letter s shortcut key cycles between selecting the Object Select tool and the Group Select tool. With the Object Select tool you can only select all
objects in a group. Clicking on one object selects them all. With the Group Select tool you can select individual objects within the group. Be careful though because the individual objects can also be moved with the Group Select tool.

If you like this method of creating designs, experiment using the same letter but changing the point of rotation to create a different design. Use different letters and/or change the Rotation Angle. Here's a lowercase letter 'g' with the
rotation point near the bottom of the letter, with 7 duplicates set to rotate at a 45 degree angle:

Figure 27 - A design using the letter g.

Pattern Definition Box Options

New in Expression 3 is the ability to change the way the Pattern Definition box behaves. The default behavior is to keep the definition box visible after defining a pattern. In this case, once the pattern is defined, you must select the definition box and delete it manually. The other available
option is to have the definition box automatically disappear after defining a pattern. To change the definition box behavior, choose File > Preferences and choose the Tools option from the drop down box. The last item in the General Options section is labeled 'Define pattern: keep def. box.' Placing
a check mark in this box causes the definition box to remain after defining a pattern; unchecking the box causes the definition box to disappear. As you work with making patterns in this lesson, you will want to decide which option works best for you.

You may have noticed that when you edit a pattern, by either double clicking on the pattern in the Pattern Preview or by using the Edit button on the Paint Style palette, the Pattern Definition box opens in a new document window. You can delete the definition box using the delete key but the
new document window will remain. For this reason, when editing a pattern it is best to get rid of the definition box by closing the new document rather than deleting the definition box. Otherwise, you'll have lots of opened documents and you may forget what they are for.

Gradients

Choosing the gradient button reveals a list of available gradients below the Fill Preview. You choose gradients by clicking on a gradient in the list. The Fill Preview will display your chosen gradient. Gradients are applied from left to right as they appear in the gradient list. The two buttons below
the gradient list (on the right) let you choose between a linear or radial gradient. The Gradient Vector tool on the ToolBox palette allows you to change the direction of a gradient. We will try this in an exercise shortly, but first lets finish examining other gradient features available on the Paint Style
palette.

If you find a gradient in the gradient list that is close to, but not exactly the gradient you want, choose a gradient that comes close to what you want and then either double click on the Fill Preview, double click on the gradient in the gradient list, or choose the Edit Gradient button under the
gradient list to display the gradient editing section of the Paint Style palette. To create a new gradient, choose the New Gradient button. To delete a gradient, choose the gradient you want to delete and click the Delete Gradient button. Again, use caution here because the only way to get the
gradient back is to reinstall Expression. Gradients are stored in a text file and deleting a gradient deletes that gradient information from the text file. If you are unsure about your decision, copy the grad.txt file in your Expression 3 directory and save it to another location for later retrieval. Lets do
another exercise and test the gradient features.

Exercise 5: Choose the Rectangle tool from the ToolBox, choose the No Stroke button and the Gradient Fill button. Select a gradient from the gradient list, choose the Linear Gradient button, and drag a rectangle. Your rectangle is filled
with the gradient you chose. Here's my rectangle:

Figure 3 - A gradient filled rectangle.

Choose the Gradient Vector tool in the ToolBox (fourth tool on the bottom row; fouth button in the second row if you're using the Expression 3 preview version) and click on the upper right-hand corner, drag to the lower left-hand corner
and release the mouse. Notice that your gradient is now applied at the angle you dragged with the Gradient tool. Here's mine.

 

Figure 4 - A gradient redirected with the Gradient Vector tool.

Drag from top to bottom with the Gradient Vector and notice how it affects the direction of the gradient. Drag in other directions and notice the change. Try dragging from above the rectangle to below it and notice that more of one color in
the gradient is applied than would be the case if you had dragged in the same direction within the rectangle.

Now lets create a new gradient. Choose the New Gradient button, type a name in the resulting dialog box, and click the Yes button to close the dialog box. Your new gradient is listed in the gradient list and is currently the active gradient.
Our new gradient looks just like the one chosen when we chose the New Gradient button and we don't want this so lets edit the new gradient. Either double click on the new gradient in the list, double click on the gradient in the Fill
Preview, or click on the Edit Gradient button and notice that the Paint Style palette changes to allow editing, as seen in Figure 5.

Figure 5 - Gradient Editing Box.

The gradient editor displays our color picker and you use this to change the colors of your gradient. The nodes under the gradient bar in the upper portion of the gradient editor determine where colors are applied to the gradient. As your
cursor approaches the nodes, it changes to a solid black cursor. Clicking on a node displays the color for that node. You can move the nodes by dragging them to the left or right. Click on the first node and choose a new color. Notice that
dragging the color wheel has an immediate effect on the gradient bar. When you have selected the color for the first node, select the second node. Again the color in the color picker changes to reflect the color on the gradient bar. Choose
another color and notice that the gradient bar changes to reflect the new color. You can add nodes to add more colors to the gradient by clicking under the gradient bar in the location where you want the color to apply. Notice than when
you move your cursor away from an existing node, the cursor changes to white with a little box to the right, indicating that it is ready to place a node when you click. Click in the center of the gradient to place a new node. Choose a color
and the new color is applied to the new node. To remove a node, click on it and drag it down until it disappears and release your mouse button.

You can apply transparency to any node. Simply select the node by clicking on it. The node will change to display the color associated with the node. Move the slider below the gradient bar to the right to increase transparency, or to the left to decrease transparency.

The small triangle above the gradient bar is the midpoint marker that indicates where a color and transparency value lie. Move the marker to the left or right to change the midpoint, or the point at which the gradient begins to blend. When you are satisfied with your new gradient, click on the
Commit button (the red check mark) to save the changes to the new gradient. Click on the Cancel button (to the left of the Commit button) to cancel the changes.

Homework Assignment

Enough talk already! Let's get down to some serious fun. You've been given a lot of information and the only good way to digest it is to practice what you've learned. So go ahead and create patterns using each of the methods presented here. Work with the Text tool until you are comfortable
with it. The following suggestion might be a good way of practicing Text tool techniques:

You've been given many new shortcut keys to remember in this lesson. Something I found useful when I was learning the shortcuts was to create a reference document and open it while I was working in another document. All I needed to do was switch to the reference document to remember
a shortcut. If you find this useful also, create a reference document and use the Text tool to enter the shortcuts you want to remember and save it as shortcuts.xpr. Open this document whenever you open Expression and then open another document that you intend to create your artwork on.
When you need to remember a shortcut, simply switch to the reference document using the tabs at the bottom, right hand corner of the document window. Naming the document shortcuts.xpr with cause the name 'shortcuts' to appear on the document tab at the bottom of the document window so
you know which one is the shortcut document.

This concludes lesson 2. Next week we will start exploring the drawing tools and learn what skeletal strokes are all about. See you then!

All material presented in this course is ©2003-2005 Annie Ford
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Lesson 3

Using the Drawing Tools

In lesson 2 you learned that there are two types of objects; simple objects and path objects. We explored simple objects in lessons 1 and 2. In this lesson we will learn to create and edit path objects using the drawing tools available to us in Expression 3. Let's take a look at these tools before
we examine just what a path object is.

The Drawing Tools

Expression has four drawing tools. When a drawing tool is selected, option buttons for that tool appear at the right end of the ToolBox. For all tools except the Freehand tool, the option buttons are Append and Do Not Append. These options allow you to start a new path from the end of another
path, or not, depending on which option is chosen (more on this as we progress). With the Freehand tool, the options that appear allow for stylus pressure. Stylus pressure only works with skeletal strokes, not with plain or gradient strokes.

The Freehand tool and the Pen tool are located on and under the 3rd button in the top row of the ToolBox. The Freehand is the easiest tool to use and the Pen tool is the most difficult tool to learn. With the Freehand tool you just draw on the document window just like you would draw on paper
with a pencil. If you want to get right down and technical about your drawing, you'll want to master the Pen tool.

The B-Spline and Polyline tools are on and under the 3rd button in the bottom row of the ToolBox. The B-Spline tool is another easy to use tool for creating smooth curves and lines. The Polyline tool is similar to the B-Spline tool but this tool makes sharp corners rather than curves. We will
examine each tool in turn, but let's start with understanding what a path is before we learn how to make one.

Anatomy of a Path

A path is a trail of segments joined together by nodes. Nodes can be thought of as tiny, multi-purpose connectors which define a portion of the segment on either side of that node. The connector defines such things as whether the segment leading away from that node should be a continuation
of the segment leading into it, or whether there should be a break so that a sharp corner is created rather than a smooth curve. The beauty of paths is that a path can be changed after it is created because paths are not "glued to the page" liked pencil strokes are glued to paper. A smooth path can
be converted to a path with sharp corners, and sharp corners can be converted to smooth paths. You can change a sharp corner to a cusp, where the segment leading into a node is sharp and the segment leading away from the node is curved, and vise versa. In addition, unlike other drawing
software, Expression gives you the ability to create different types of curves; Bezier and B-Spline.

A Bezier curve is a curve where the node is attached directly to a path while a B-Spline curve is described by a node that is not attached. Below is an example of Bezier curves.

Figure 1 - An example of Bezier curves.

Notice the small squares at the beginning and end of the path as well as in each place where the path curves. These are nodes. In a Bezier curve, the nodes contain tangent handles which look like lines that extend on one or both sides of the node. This type of curve is edited by adjusting the
node itself or by adjusting the tangent handles on either side of the node. The following example illustrates a B-Spline curve.

Figure 2 - An example of B-Spline curves.

In this example, with the exception of the nodes at the beginning and end of the path, the nodes are not attached directly to the path and the nodes do not have tangent handles. B-Spline curves are edited by moving the nodes above or below the curve.

Notice, in both examples above, that the first node on each path has a plain node while the nodes at the right end of each path has an arrow and another strange object attached to it. The arrow indicates the direction of the path. The first click you make on the view area will always be the
beginning of the path and the other end is the end of the path. The arrow simply shows you in which direction you drew the path. From the examples above you can see that I drew each path from left to right.

The other strange object at the same end as the arrow is the stroke width handle. It works like the Stroke Width meter on the Paint Style palette. Pulling on the stroke width handle away from the path will widen the stroke attached to the path and pushing towards the path will narrow the
stroke.

The stroke width handle, and all nodes along a path, are adjusted with the Node Tool. A node must be selected to adjust it. Notice in the examples above that some nodes are hollow and some nodes are solid. Hollow nodes are deselected while solid nodes are selected.

Let's get a little hands on experience here. Click on the Freehand tool (third button in the top row of the Toolbox) and draw a squiggly line on the document window (view area). With the Freehand tool, a path begins at the point where you start to draw and ends when you lift the mouse off of
the view area. Now click the shortcut letter n on your keyboard (to choose the Node tool) and approach the stroke width handle by the arrow at the end of your path (your squiggly line). Notice how the cursor changes to a cursor with a 'width handle' image below it, indicating that you are about to
adjust the width of the stroke attached to that path. You can see that cursor in the image below:

Click on the handle and drag away from the path and notice that a ghost copy of the stroke width handle follows the cursor to show you the direction you are dragging. This is useful because you 'shear' a stroke if you drag at an angle rather that straight away from the path. More on that later.
Here's what that ghost image looks like:

Look at the status bar as you drag. It will tell you the stroke width in points so you can drag to a precise width. Once you release the mouse, the stroke width is registered in the PaintStyle palette, on the stroke width meter, and your path reflects the new stroke width.

Notice that all nodes on the path above are solid, meaning that all of the nodes are selected. This is because the operation we just performed (changing the stroke width) affected all of the nodes on the path. Click on one node on the path and notice that all other paths become deselected.

More than one node may be selected at one time. To do this, click on a node and hold down the Shift key while clicking on other nodes to add to the selection. When more than one node is selected, any adjustments you make will affect all selected nodes.

Paths can be open or closed. An open path is a path where the beginning and the end of a path are in different locations. A closed path is one where the beginning and end of a path are in the same location. When you draw with any drawing tool, the cursor for that tool will change depending
on the operation you're performing. For example, the Freehand tool looks like a pencil when you are drawing an open path, but as you move close to the beginning of a path, a small circle will appear to the right of the normal pencil cursor indicating that clicking at this point will create a closed path.
We just saw an example where our node editing cursor changed to tell us that we were about to adjust the width of the stroke on our active path. You will learn to appreciate these helpful "road signs" on your way to making paths in Expresion 3.

We will work with editing nodes, and various operations associated with creating and editing nodes, a little later in this lesson. For now, let's take a look at the drawing tools. There is more to the Freehand tool than we've learned so far so let's start there.

The Freehand Tool

The Freehand tool, the third button in the top row of the ToolBox, displays a paint brush icon on it's ToolBox button (but the Freehand cursor is a pencil; go figure). The lowercase letter 'p' shortcut key cycles through all of the tools that occupy this space on the ToolBox (the Freehand, Pen and
Bitmap Pen tools). With the Freehand tool, you simply draw a trail with your mouse or stylus where you want the path to be formed. The trail is fitted with Bezier curves to form the path. The tangent handles on a Freehand path won't be readily visible until you click on a node along the path with
the Node tool. The Node tool, remember, is the tool you use to edit nodes on a path.

The Freehand tool works with a regular mouse as well as a stylus (pen mouse if you prefer). If you are fortunate to have a stylus, the options on the right side of the ToolBox give you the ability to vary the width and transparency of a stroke according to the pressure you apply when drawing. Notice
the button with a swish icon which appears depressed in the screen shot on the left. This is the Variable Width on/off switch. If you use a stylus, pressing this button makes your Freehand tool pressure sensitive to the stylus. The more pressure you apply, the wider the stroke will be. The stroke
becomes thinner as you lighten the pressure. The Variable Width button has no effect if you don't have a stylus or you aren't using it with the Freehand tool.

The meter to the left of this button is the Maximum Pressure Width meter. This meter corresponds to maximum pressure and sets the maximum width of a stroke. My meter is set to 80 pixels so the maximum stroke width using maximum pressure on my stylus is 80 pixels. If I reduce the value
to 40, the maximum width of my stroke will be no wider than 40 pixels. Experiment to determine your preference. Expression will remember your setting with each launch until you change it.

The slider below the pressure width buttons allow you to control how much stylus pressure will apply to stroke width and how much it will affect stroke transparency. If, for example, you want a stroke to become more transparent with increased stylus pressure, move the bottom slider further
to the right and the top slider further to the left. If you want stylus pressure to affect stroke width to a greater degree than it affects transparency, move the top slider further to the left and the bottom slider further to the right. These sliders affect bitmap strokes only. We will discuss the difference
between bitmap and skeletal strokes in lesson 4, but if you want to experiment with the sliders, use the strokes in the Water strokes folder as these are bitmap strokes. See the discussion on The Stroke Palette below to learn more about accessing strokes in the Strokes palette.

When the Variable Width button is active, your settings will apply to all subsequent paths you draw but will not change an existing path. You can disable the Variable Width meter in which case both the Variable Width meter and sliders disappear.

As mentioned earlier, with the other drawing tools the options that appear at the end of the ToolBox are Append and Do Not Append which allow you to continue a previously drawn path, or not. Since there's no room on the ToolBox for these options with the Freehand tool you need to hold the
Alt key to append (add) to a freehand path. Try this: choose the Freehand tool and draw a path on your document. Now move your cursor close to the beginning or end of the path. Nothing happens. Now hold press the Alt key and move your cursor to the beginning or end of the path again and
notice that a little squiggly line appears next to the cursor. This indicates that the path you are about to draw will attach itself to the point of the existing path you're close too. Now draw and short path, release the mouse and notice that the new path attaches to the original path.

The Freehand tool also acts as a selection tool, regardless of the tool used to create the stroke, but only to a certain extent. You can select any path with the Freehand tool but only to make the stroke active. Say for example, you want a B-Spline path active to apply a new stroke color to it, or
to delete it, but your currently active tool is the Freehand tool. Simply click on the B-Spline path with the Freehand tool and make your changes. No bounding box will appear on the selected path so you can't move, resize or rotate the path.

For people who don't have a stylus, or choose not to use it, you can achieve the same variable width and transparency effects using the Variable Width palette. Let's take a look at that next.

The Variable Width Palette

Open your Variable Width palette by choosing Window > Variable Width from the menu bar or by pressing the F7 shortcut key. The palette will dock itself with the other palettes on the left side of the screen. If the palette is minimized, click the "Restore Minimized Window" button to the left of
the "Close" button to maximize the palette.

Notice the large area which is light gray on the top and dark gray on the bottom. This is a graph which represents the stroke on the currently active path. The left side of the graph represents the beginning of a path and the right end represents the end of the path. To follow along with this
discussion, draw a path on the document (view area) with the Freehand tool. Click on the second button from the left on the Variable Width palette (represented by a + icon) and notice that two nodes are added to the line on the graph. These nodes, again, represent the beginning and end of the
path. Click the button again and another node is added to the center of the graph. Your Variable Width palette should now look like this:

Figure 3 - The variable Width palette with a node added.

Click on the center node and drag it to the top of the graph and notice that the stroke in the center of your path got wider. Click on the center node again and this time drag it to the bottom of the graph and notice that the stroke got narrower this time. You can add more nodes using the +
button and a new node will appear on the graph to the right of the currently active node. Like paths themselves, the nodes in the graph are hollow when deselected and solid when selected. You activate nodes on the Variable Width palette by clicking on them. Once active, you can delete nodes
using the - (minus) button, slide the nodes back and forth along the graph, or move them up or down to widen or narrow a stroke along the active path.

The Variable Width meter comes with a set of variable width profiles, called presets. Click on the button to the left of the minus button, labeled Preset Profiles on the tool tip, hold down on the mouse as you scroll through the list, releasing the mouse when you reach the preset you want. Just
for fun, choose the 7th item in the list and notice how this affects the stroke on your path and that the nodes on the graph correspond to the preset. You can save your own presets using the 5th button from the left which displays the 'Add to Presets' tool tip The next button allows you to edit the list
of presets. The last item in this row of buttons is the same Width/Transparency meter found on the ToolBox when the Variable Width button is active for the Freehand tool.

Settings in the Variable Width palette apply to the currently active path as well as to all subsequent paths you create. Therefore, if you don't intent to apply a setting to an active path or subsequent paths, click on the first button on the palette (the Reset button) to clear the settings.

The B-Spline Tool

The B-Spline tool is the next easiest tool to learn and use. To use it, choose the tool (lowercase letter w) which is the third button in the bottom row of the ToolBox and click on the view area to place the first node. Continue clicking to place nodes along the path. To end an open path, double
click where you want to end the path or end the path by pressing the Enter key (Return key on a Mac) on your keyboard. To end a closed path, move the cursor to the beginning of the path and click when the cursor changes to add a circular shape next to the regular cursor and click once. The
result will be curved segments along the path. If you hold down the Alt key (Option key on the Mac) before clicking to place the next node you can create sharp corner nodes instead of curves. Let's do an exercise and learn about the B-Spline tool.

Exercise 1: Clear your view area or open a new document. Display the grid lines by choosing View > Show > Grid from the menu bar. Grid spacing should be about 1 inch between grids. If you need a bigger grid, choose File >
Preferences and choose View and Display from the option box at the top of the Preferences dialog box. Type "1 in" in the Grid Spacing box and close the Preferences dialog box.

With the B-Spline tool, make your beginning point by clicking on an intersection on the grid towards the bottom center of your document. Count four intersections to the left, up four intersections, and click again to place your second node.
Count up two intersections, two intersections to the right, and click to place your third node. Count two intersections to the right, down two intersections, and this time hold down the Alt (Option) key and click to place your fourth node.
Stay with me as we count to the right two intersections, up two intersections, and click to place the fifth node. Once more we will count two intersections to the right, down two intersections, and click to place our sixth node. Finally, hold
down the Alt (Option) key and click on top of your beginning point to create a closed path. Now look at your object which should look like this:

Figure 4 - The Perfect Heart Shape.

Unless you changed a setting, the stroke on your heart is wider than it is on my stroke. The default stroke width is 10 points. Instead of using the Paint Style palette, let's change the width using the stroke width handle. This handle,
remember, is next to the arrow at the end of the path. In our case, the end of the path is at the bottom of the heart shape. Choose the Node tool (lower case letter a or lower case letter n), click on the width handle and drag it closer to
the arrow on the path. Release the mouse and your stroke should be narrower. Pull on the width handle away from the arrow and the stroke widens. This is a shortcut to the stroke width meter on the Paint Style palette, but not as precise.
To get an exact stroke width, use the Paint Style palette.

With the heart shape, we created curves by leaving large spaces between clicks resulting in nice wide curves. With shorter spaces between clicks you create smaller, shorter curves. This makes the B-Spline tool a great tracing tool. Let's do another exercise and learn how to trace images. First,
hide the grid since we won't need it for this exercise and delete your heart shape. Next, download the Ed.zip file, upzip the ed.tif image and bring the image into Expression by choosing File > Insert Bitmap from the menu bar. Because the image is a bitmap image, a red grid appears above the
image. If the image appears small, click on the image with the Object Select tool and drag the resize handles to enlarge it. The following screen shot is the finished version of Ed. Now, on with the exercise:

Figure 4 - Ed.

Exercise 2: Ed should now be opened and enlarged in your view area. Open another document and choose View > Onion Skin > Show Previous or Ctrl-K. You should now see a faded version of Ed in your new document. The Ctrl-K
key combination toggles between hiding and showing the faded image which is handy when you want to view your work without the preview image showing from behind.

Choose the B-Spline tool and notice the two buttons at the right end of the ToolBox. The first one is the Do Not Append button and the next one is the Append button. When you are working close to another path, you sometimes want your
next path to continue on from the path you are close to and sometimes you don't. Click the Append button so that if you accidentally end a path, you can click close to the end of that path and continue from where you left off. Now,
beginning at the top of Ed's head, begin tracing by clicking at various points around Ed's face. When you want smaller curves, leave less space between your next click and the last one, or longer spaces when you want larger curves. When
you come to places where you want a sharp corner, around Ed's ears for example, hold down the Alt key before clicking to place the next node. When you come back to the top of Ed's head, click to end the path when the cursor changes
to a closed shape cursor.

It's important to note here that if you make a mistake, press the Delete key on your keyboard to back up one node. Clicking once takes you back one node; clicking again will delete the entire path so be careful.

When you're done tracing Ed's face, click the Fill button on the Paint Style palette and choose a nice flesh tone color. If you want, copy the following numbers to the clipboard ( #FFE4C4 ), click on the area below the color triangle on the
Paint Style palette, then right click on this same area and choose paste from the menu. Press the Enter (Return) key on your keyboard and the new color is entered on the Paint Style palette. Ed's face should now be filled with a flesh
color. Click away from Ed's face to deselect it. If you want, use the shortcut Ctrl-K key combination to hide the bitmap image and view your work. Give your stroke a smaller width if you want. When you're ready, use the Ctrl-K shortcut to
make the bitmap image visible again.

We know what happens when you fill a closed path but what about filling opened paths? We've only worked with closed shapes so far. Make sure Ed's face is deselected and choose a darker skin tone fill color. To do this, just click on a
darker area in the color triangle on the Paint Style palette. Now trace around the shapes on the inside of Ed's ears with the B-Spline tool and double click when you want to end the path. Notice that the fill applies to open paths as well as
closed paths and that the fill runs from the beginning of the path to the end of the path.

Deselect everything in the view area and click the No Fill button on the Paint Style palette. Using the B-Spline tool, continue tracing the other items on Ed's face, such as his hair, nose, mouth and eyes. When you get to his eyes, you may
want to switch to the Ellipse tool and use a solid black fill. We'll leave Ed's neck and shirt collar until later. Right now let's take a look at the Strokes palette and really give Ed some flare!

I might mention here that you'll find additional information on the B-Spline tool in the Expression 3 user manual beginning on page 165; Tutorial 1: Easy Paths and the B-Spline Tool.

The Strokes Palette

Until now we've used the default stroke for all of our shapes and paths. Other strokes are available when you choose the Skeletal Stroke button on the Paint Style palette and these additional strokes live in the Strokes palette, seen here on the left. Strokes are special files stored in the Expression
3/Strokes sub-directory on your hard drive and some strokes are stored in sub-directories under the Strokes sub-directory. These strokes appear in the stroke list in the Strokes palette. You can switch between sub-directories using the drop down list at the bottom right corner of the Strokes palette.
If you have several sub-directories, the drop down box will display a scrollbar which allows you to scroll through the list of sub-directories. The top item in this drop down box lets you display all of the strokes regardless of the directory a stroke is stored in.

Hide Ed's bitmap image for now, leaving only the document you're working on visible, and click on the outline of Ed's face. Assuming that you have a skeletal stroke applied, navigate through the directory drop down list and choose the Dry directory (or folder if you prefer). The list of strokes in
the stroke list was replaced with a list of strokes in the Dry folder. From this list of strokes, choose the 'pencil' stroke. Notice how Ed is updated with the new stroke. If you need to, change the stroke width on the Paint Style palette to a larger or smaller size. Next, click on one of the hairs above Ed's
ears. Hold down the Shift key and click on the remaining hairs. Holding the Shift key allows you to select more than one object at a time, you remember. If you accidentally select a path you didn't intend to select, click on the path again to deselect it without deselecting the other paths. Choose a
stroke and the stoke will attach to each selected path.

I'll save the other items on the Stroke palette for discussion when we learn to create strokes in lesson 4. For now, continue to work on Ed by selecting different paths that make up his face and apply different strokes. When you're ready, read on to learn about the other drawing tools and we'll
get back to Ed a little later.

The Polyline Tool

The Polyline tool is similar to the B-Spline tool. With this tool you click to place your first node and continue to click to place subsequent nodes and double click to end an open path. The difference between the tools is that subsequent clicks with the Polyline tool creates sharp corner nodes
instead of curves. Below is an example of a simple zig zag path created by clicking on various grid intersections with the Polyline tool:

Figure 5 - Simple zig zag path using the Polyline tool.

With the Polyline tool you can also create curves by clicking and dragging. The curves created with the Polyline tool are very round, as you'll see. This is a little tricky to explain, so bear with me. Suppose that, instead of just clicking at the points on the grid as I did in the above example, I
clicked and dragged instead. Doing so would create a scallop instead of a zig zag:

Figure 6 - Simple scalloped path using the Polyline tool.

Let's do another exercise to fully understand the Polyline tool.

Exercise 3: Open a new document and display the grid. Choose the Polyline tool (lowercase w). Click on a grid line intersection to place your first node. Move up two intersections, click again (but don't release the mouse) and drag down
to the second intersection to the right of your first click, release the mouse and click on that intersection. To make this a little more clear, consider the following diagram:

Where my scallop begins is where I clicked to place my first node. The tiny circle at the intersection two grid intersections up and one intersection to the right is where I clicked and dragged down to the intersection where you see the
Polyline cursor. Where you see the cursor is where I released the mouse and clicked to place the node. Continue this click-dragging-click until you get to the point where you want to end the path and then double click to end it.

You can combine sharp corners and curves in the same path. Let's make a sailboat. Clear off your view area (don't delete Ed!!) and click on a grid line with the Polyline tool to place the first node. Count 3 intersections to the left and click
to place the second node. Count up 5 intersections and click to place the third node. Next, click anywhere to the right of the last node you place and click-drag down to the first node you placed and, when your cursor changes to indicate
that you are over the first node, click to end the path. (Remember, double clicking ends an open path and clicking once over the beginning of a path ends a closed path). You should have something like this:

Notice that it didn't matter where you click-dragged to create the curve. The Polyline tool will always create a circular curve. Try another sail and click-drag further away than you did the first time and you'll see that the results are the
same. Add a simple bottom to the sail boat by simply clicking to create corner points.

Notice that a node is not created at the point where you click-drag. Nodes are placed only where you click and release the mouse. Clicking and dragging tells Expression to create a circular curve between the last node you created and the
next one you are about to place. Let's make water for our sailboat. Below is a diagram so you can see the intersections I'm referring to in the following explanation:

Click on a grid intersection to place the first node. Click-drag (upward) anywhere to the right and click on the intersection two intersections up from the first node. A node will be placed at this intersection. Click-drag to the right again
(dragging down this time) and click on the intersection two intersections to the right of your first node. Continue doing this until you want to end the path and double click to end it. When you're finished, notice how nodes are not placed
where you clicked and dragged to create the curve, but that nodes do appear in the center of each curve. Click on any node on the path with the Node tool and notice that tangent handles appear on each node that effects that curve, as
shown below:

First, the tangent handles tell us that these curves are Bezier curves which can be adjusted by moving the node itself, or by adjusting the tangent handles attached to the node. These are not B-Spline curves like those made with the B-
Spline tool.

Click the Fill button on the Paint Style palette and notice that your waves fill with color from the first beginning node on the path to the ending node. Choose a blue color for the fill. Then select any other sailboat parts and fill those with
color as well. Get creative! Experiment with gradients.

If the Polyline tool is a tool you will use often, by all means experiment with it until you fully understand how it works. Let's move on to the Pen tool which has some similarities to the Polyline tool.

The Pen Tool

Fasten your seat belt. The Pen tool, in my opinion, is the most difficult tool to learn. The Pen tool is located below the Freehand tool in the ToolBox (lowercase letter p on your keyboard). Like the Polyline tool, you can click to place the first node and continue to click to create corner nodes. If
you use the Pen tool and click to make the zig zag path we made earlier with the Polyline tool, the results would be the same. Double clicking ends the path. Moving to the beginning of the first node on a path will cause the cursor to change, indicating that one click will end the path to create a
closed path. Like all of the other tools, except the Freehand tool, you have the option of choosing Do Not Append or Append using the option buttons on the right end of the ToolBox.

The Pen tool will also create Bezier curves but these curves are not circular and are created differently than those created with the Polyline tool. When you click-drag with the Polyline tool, you are not placing a node, but rather, you're telling Expression to create a curve between the last node
you created and the next node you place. When you click-drag with the Pen tool, you are actually placing a node and pulling out tangent handles to describe the angle and depth of a curve between curved segments. The entire curve in the curved segment will be influenced by the next node you
place. Let's use the Pen tool and try and create the scallop we created earlier with the Polyline tool. If I click on an intersection and then click-drag to the second intersection to the right of the first node, a node is place at the point where I click-dragged, with tangent handles now appearing:

Notice from this screen capture that what is being dragged is a tangent handle. If I click on the intersection where the cursor is, or double click to end the path as I did here, a completely different curve results from the one made with the Polyline tool:

Notice what happens when I adjust the tangent handles for the second node:

Let's create a simple teardrop shape and grasp the concept of tangent handles

Exercise 3: Find space on your document window or open a new document. With the Pen tool click on a grid intersection to place the first node. Click on the second intersection above the first node and click-drag one intersection to the
right, like this:

Release the mouse and click on the first node to close the path, like this:

The tangent handles aren't visible so choose the Node tool (lowercase letter a) and click on the second node (the node at the top of our path) to reveal the handles:

Because we click-dragged to place the second node, a curve was created instead of a sharp corner. You can adjust the curve by dragging the second node itself. Test this by clicking on the second node and dragging it down one
intersection and release the mouse:

Now click on the right tangent handle and drag it to the right one intersection and release the mouse to adjust the curve on the right side of the node:

Only the curve on the right side of the node was effected. To change the way tangent handles behave we need to take a look at the Attributes palette. Let's do that now.

The Attributes Palette

A path can have both continuous and discontinuous segments. A continuous segment means that a curve on both sides of a node will be influenced by the tangent handles so that a smooth path will result. A discontinuous segment means a break in the node so that only one side of the curve is
influenced, as in our exercise above. We'll use the buttons on the Attributes palette, outlined in red in the image on the left, to create continuous and discontinuous segments.

Clicking the first button will cause both tangent handles to move together so that one tangent handle will always be opposite of the handle being moved. With this button, dragging the right tangent handle down will cause the left tangent handle to move up an equal distance with that of the right
handle. This creates a smooth path but the curve on one side of the node will curve in the opposite direction than the curve on the other side of the node. Moving the right handle outward, as we did in the last exercise, will cause the left handle to move to the left an equal distance.

The second button, which displays a "Smooth" tool tip when moused over, will also cause one tangent handle to move an equal distance in the opposite direction when the opposite handle is moved up or down, but only the handle being dragged will move if you drag the handle to the left or
right causing only the curve on the side of the node of the handle being moved to be affected. Both the first and second buttons maintain path continuity.

The third button creates discontinuity at a node so that the handle opposite of the handle being dragged is locked. Only the handle being dragged will move so that only the curve on the side of the path being altered with the tangent handle is affected.

The fourth button maintains a relative angle of the tangent handles. Consider the following example where I have adjusted my tangent handles at the top of my teardrop shape as follows:

If I drag the right tangent handle, the opposite handle will move to maintain the angle of the tangent handles, like this:

From the outline showing the results of my dragging motion you can see that the angle of the tangent handles is maintained when the last button (Angle Locked) button is active.

Like I said, the Pen tool is hard to learn and all aspects of this tool would take an entire lesson of it's own to cover. If you feel brave enough to tackle this tool, open another copy of Ed in a new document and try tracing the face with the Pen tool this time. When time allows I will cover this tool
in depth in an advanced Expression 3 class.

Adding and Deleting Nodes

There will be times when you will want to edit a path by adding or deleting nodes. The Add Node and Delete Node tools both occupy the 5th space in the bottom row of the ToolBox. The lowercase letter 'm' cycles through these tools. To add a node, choose the Add Node tool and click anywhere
along a selected path to place a node there. To delete a node, choose the Delete node tool and click on any node on a selected path to delete that node.

Selecting Multiple Nodes

You can select more than one node for editing at one time and there are three ways to do this. The first way is to select a node with the Node tool and then hold down the Shift key while you click on other nodes. If you accidentally choose a node you didn't intend to select, click on it a second
time to deselect it without deselecting other nodes. When more than one node is selected, any editing you do will affect all selected nodes.

Alternatively, if the nodes you want selected are close together, you can drag a marquee around the nodes you want to select with the Node tool. Try this on Ed. Click once on the outline of Ed's face with the Node tool to select the entire face shape. (Clicking once on a path selects the entire
path so that the nodes become visible). Then drag a marquee around three of the nodes in Ed's ear, like this:

When you release the mouse you'll see a bounding box around the only three nodes selected, like this:

At his point, if you pull or adjust one node within the bounding box, all of the nodes within the bounding box will be affected. Try this yourself. If you don't like your modification, choose Edit > Undo from the menu bar to reverse the editing.

The third method of selecting multiple nodes is by using the Node Lasso tool, which resides below the Node tool (first tool in the bottom row of the ToolBox). You'll use this tool when you need to select multiple nodes that cannot be selected with a marquee. To do this, select the Node Lasso
tool and use it like a pencil to draw around the nodes you want to select. Below is an example of this method of node selecting:

When you release the mouse after drawing, the nodes you captured will be solid red, indicating that these nodes are selected. Again, anything you do to one node will affect all other selected nodes.

Converting Nodes

When you want to convert a curved node into a sharp corner node, and vise versa, use the Node Convert tool which also resides under the Node tool on the ToolBox. Any node can be converted using this tool, but only to convert between curved and corner nodes. You cannot convert a B-Spline
curve to a Bezier curve with this tool.

Stacking Order

When you create objects in the view area, each object you create is on top of the last one you created. This is referred to in Expression as the 'stacking order.' Stacking order becomes important when you want to create objects between other objects. Consider Ed, for example. We have created
a number of paths on top of the face shape, including Ed's eye, his mouth, eyes, eye brows and several other objects. But what if we want to add a little shading to Ed's face? If we create new objects for shading now, how are we going to place them below all the other objects above Ed's face?

Expression has menu items to move objects up and down in the stacking order. Choose the Arrange menu item and notice the first 4 items listed there; To Front, To Back, Up One and Down One. We're going to finish Ed as I explain the stacking commands so go back to that document now
and follow along. Finishing Ed is your homework assignment for this lesson.

First thing we need to do is click on Ed's face to select it. You will remember that the face was the first object we created so it is on the very bottom of the stacking order. Press the Ctrl-D key combination on your keyboard to duplicate the face shape. The duplicate should now be on top of all
other paths. We don't want to disturb the other objects under the duplicate so let's lock them. Right click on the view area and choose 'Select All' from the context menu. This selects everything, including the duplicate. Hold down the Shift key and click once on the duplicate to deselect it from the
other selected objects. Now choose Arrange > Group from the menu bar. Right click on the view area again and choose 'Lock Object.' Because we deselected the duplicate, everything in the view area is locked except the duplicate that we want to work on.

It is important to explain why we grouped the objects before locking them. You can lock several objects at once by selecting them and choosing the lock operation as we did before, but to unlock them again, you need to choose each item and unlock it individually. This becomes extremely
difficult if you don't know the stacking order of the objects, and each object needs to be selected and unlocked in stacking order. By grouping the objects first, you can unlock them all at once.

Select the duplicate and choose the Delete Node tool (lowercase m). Click on each node in the left ear of the duplicate until the ear disappears. Do the same thing with the other ear. You should now have a duplicate of Ed's face minus his ears. Click on the No Stroke button on the Paint Style
palette to remove the stroke from the duplicate. Hold the Shift key down as you click and drag on a resize handle on the bounding box to reduce the size of the duplicate to approximately two-thirds it's original size. On the Paint Style palette, choose a skin tone color a shade or two lighter than the
color used in Ed's face. (You can paste the color we used earlier and reduce the lightness value in the HSL color picker, or just choose a lighter color.) Click on the Soft Edge/Emboss meter and enter a value of about 40.

You've created a shading object and this object needs to be one object above Ed's face. Move this new shading object out of the way for a moment and then click on the grouped/locked objects, right click on the view area and choose Unlock from the context menu. All of the objects will be
selected because they are still grouped togehter. Choose Arrange > Ungroup and then deselect the objects. Move the new shading object over the other objects and position it so it's approximately in the center of Ed's face. From the menu bar, choose Arrange > To Back and then Arrange > Up
One. Doing it this way was much easier than continually choosing Arrange > Down One until you reached the proper position in the stacking order, but it could certainly be done this way.

Homework Assignment

Your homework assignment is to complete Ed. You might give Ed's face a second layer of shading (my Ed has three shading layers). If you find that the shading isn't as soft as you'd like, try moving the transparency slider for the fill color to soften it. You'll also need to create Ed's neck and
move it to the very back. Maybe you'll want to add shading to the neck as well. Then create the collar on Ed's sweater. You might want to look through the Strokes palette and choose different strokes for the collar. Give the collar a fill color and maybe a texture or pattern. Anything goes here. Above
all else, have fun!

Also, make copies of the Ed bitmap image and try tracing with the other drawing tools. Decide which tools work best for you and work with them until you are comfortable using them.

This concludes lesson 3. Next week we will examine how strokes are applied to a path, the difference between skeletal strokes and bitmap strokes, and we will learn to make our own strokes. The fun never ends! See you then.

All material presented in this course is ©2003-2005 Annie Ford

https://web.archive.org/web/20060131031113/http://www.studioe3.com/lessons/images2/ed.zip


Lesson 4

Strokes 101

This lesson is all about making and using strokes. We'll start by looking at how strokes are applied to a path and what you can do to a stroke once it's applied. Then we'll go into the mechanics of creating strokes. Let's get started.

Applying Strokes

In the last lesson we learn about the direction of a path and that the arrow at the end of a path indicates in which direction the path was drawn. It is important to consider the direction of a stroke as well. Let's take another look at the Strokes palette:

In many cases, you need not be concerned about the direction of a stroke. In the last lesson we applied some strokes from the Dry stroke folder. The strokes in that folder consist of natural media type strokes and direction with this type of stroke really doesn't matter because the stroke looks the
same on both ends. But consider the strokes in the palette on the left. These strokes are graphic style strokes and with this type of stroke, direction matters.

Strokes are applied to a path in the direction they appear in the Strokes palette. The left end of the stroke is always applied to the beginning of a path and the right end of the stroke is always applied to the end of a path. Try this: choose the Pen tool from the ToolBox and click to place the
beginning point of a path. Double click about 3 inches to the right of your first click to end the path. Click the Skeletal Stroke button on the Paint Style palette. Open the Graphics folder in the Strokes palette and scroll down to the 'dry fish' stroke and click on it to apply it to your path. (You may
want to increase the stroke width if your fish seems distorted.) Notice that while the fish seems to be pointing in the opposite direction as the path, it is applied to the path as it appears in the Strokes palette.

Take a look at the leaf stroke; the fourth stroke in the list on the screen shot above. Because the stem is on the left side of the palette, we know that it will attach to the beginning of a path. If I want the leaf to stand upright, I would have to end a path above the point where I started the path,
like this:

Remember, the arrow at the end of a path tells you in which direction the path was drawn. In the leaf example, you can see that I drew my path from bottom to top. Create a path as I did and click on the leaf stroke in the list of strokes to apply it to the path. Now click on the stroke above the
leaf stroke, named 'flowerframe' and notice that it's upside down when applied to the same path.

You are not limited to single segment paths with graphic strokes. (Remember that a segment is the section between two nodes.) Here's the leaf stroke applied to a two segment path created with the B-Spline tool:

As you can see, you can use the same stroke and make it look different just by applying it to a curved path. You can also change the look of a stroke by "shearing" the stroke. Remember our discussion on the stroke width handle? That's the funny little gadget next to the arrow on the end of a
path. Pulling it away from the path makes the stroke wider and pulling it toward the path makes the stroke slimmer. Moving it in any other direction will "shear" the stroke. Compare the leaf above with the one below and notice the difference in the angle of the stroke width handle:

Shearing can be done by adjusting the stroke width handle, as you just witnessed, or it can be done using the Attributes palette. We looked at this palette briefly in lesson 3. Let's take another look at it. Open this palette, if it isn't opened already, by choosing Window > Attributes from the menu
bar or by using the F4 shortcut key.

Mouse over the second slider from the top and the tool tip should say "Shear." Create a path and apply the leaf stroke. Move the stroke width handle on the path and notice how the slider on the Attributes palette moves. Move the slider on the palette and notice how the stroke width handles
on the path moves. Either way you choose to shear a stroke, the results are the same. You'll need to remember to set the slider to the 0 degree mark (center of the slider) when you're done because the setting on this slider will apply to all subsequent strokes you make.

We'll learn more about stroke behavior as we learn to make our own stroke. First, it's important to learn the difference in the types of strokes available in Expression.

Skeletal vs. Bitmap Strokes

You've heard me talk about skeletal strokes and bitmap strokes. Strokes can be made from one or more vector paths and this is what you normally think of when you hear the term skeletal strokes. The strokes we've looked at today are of this type. Bitmap strokes are made from a bitmap
image, such as .gif or .jpg images, but bitmap strokes are still skeletal strokes. Strokes made up of vector paths behave differently than strokes made up of bitmap images and that, in my opinion, is why you hear Expression users refer to strokes as either bitmap or skeletal. It saves them from
otherwise lengthy explanations because users know that other users know the difference.

The term 'skeletal stroke' is actually a technology which means to attach an image to a path, so to speak. The 'picture' can be either a bitmap or an image created by one or more vector paths. Let's get to this business of making different kinds of strokes so you too can speak the user lingo.

Vector Type Skeletal Strokes

Transparent style: The first stroke we will make uses transparency. Strokes containing transparency build up in color as they cross over themselves or other strokes. In the process of creating this type of stroke, we'll learn about blending paths. Ok, let's do it.

Open a new document and draw an oval shape with the Ellipse tool. Choose the No Stroke button and a black color fill. Choose Menu > Objects > Convert to Path. Convert two opposite nodes to corner points so you have something that looks like this:

Using the opacity slider on the Paint Style palette (between the Stroke Preview and the Fill Preview), reduce the opacity to 10%. Duplicate the shape and reduce it in length to about half the length of the original shape. Now place the second shape on top of the first one so that it looks like this:

Notice that although the transparency of the second shape was not changed, the second shape appears darker than the first. This is what I mean about colors building up. The transparency of the second shape allows color from the first shape to show through, giving the second shape a darker
appearance.

Select both objects and choose Menu > Objects > Blend Paths. Type 8 in the resulting dialog box and make sure the Linear Interpolate radio button is selected. Click OK to close the dialog box. You should now have something like this:

The blending path feature creates a number of additional paths from two or more source paths. The number of paths it creates, of course, is determined by the value entered in the resulting dialog box. If you want fewer blends, type in a lower number. The blends between the source paths are
grouped together but the two source paths are not included in the group. Notice, from the screen shot above that only the two source paths are selected. So click away from the paths and then select all of the paths with the Object Select tool.

We are now ready to define our stroke and one way to do that is to choose Menu > Stroke > New Stroke Definition from the menu bar. Go ahead and do that now. This brings up the Stroke Definition box which looks much like the Pattern Definition box in lesson 2. Notice the red box
around the stroke with an arrow running through it.

We'll get to the red box later. But notice the arrow. This is the direction arrow. This tells you how your stroke will appear in the Stroke palette and how it will apply to a stroke. This will become more significant when we get to graphic style strokes, as we discussed earlier. Everything looks good so
click the Define Stroke button at the bottom of the definition box and now you get a dialog box asking for the name of this new stroke, the folder where you want to store the stroke and the default stroke width. Enter your information, accepting the default width value, and click the OK button to
dismiss both the definition box and information box. Your new stroke is added to the folder you designated and it should be the active stroke.

Have you noticed that most of the strokes in the Strokes palette are black? It really doesn't matter what color you used to create the stroke because strokes can be colored, as you already know. Choose the drawing tool of your choice, draw a path and apply your new stroke to it and let's give
the stroke some color. (Note: If your stroke appears pale in color, check the transparency slider and make sure you didn't move it (the top slider) along with the fill transparency slider (the bottom slider) when we first created the paths from which to make the stroke. Now would be a good time to
set both sliders all the way to the right for full opacity.)

Notice in the Paint Style palette that the Color Preview has two boxes instead of one and that both boxes appear empty. The top box is considered the foreground color and the bottom one is the background color. Click on a color in the color triangle and your stroke takes on the new color. In
the color preview, notice that the top box reflects your color selection and the color in the bottom box is white. The reason for this will become apparent when we make our next stroke. For now, make another stroke that crosses over the first one and notice how the color builds up where the strokes
cross, like this:

Textured style: Another type of vector skeletal stroke is referred to as a textured stroke and it's this type of stroke where the bottom half of our color preview comes into play. Create a path and apply the stroke named S14 in the General folder in the Strokes palette. This is what the stroke
looks like with our color settings:

Click on the bottom box of the color preview and choose a color in the color triangle. I'm going to make my stroke real ugly and choose green:

To see what's happening here, set the stroke back to it's original colors, which are various shades of gray. To do this, click on the little colored button to the right of the transparency sliders on the Paint Style palette. This is what your stroke should look like:

From these three images you can see that the foreground color in the color preview applies from the darkest color in the stroke (black in this case) to the midrange color (medium gray here) and that the bottom box in the color preview applies to where the midrange color left off in the
foreground color all the way to white. Any vector style skeletal stroke can have color applied this way, regardless of whether it was created in various shades of gray. You might test this by downloading some of the leaf strokes on Alan's Expression Strokes page and applying different colors to them.

Graphic style: I call vector paths that make up an image and defined as a stroke a 'graphic style' stroke. Let's create one of these. Let's make life easy and use a font. Use any font you want; I'm using a leaf font from a freeware font set. Here's my leaf in fall colors:

Now this is where it's important to know how to position your stroke so that it will attach to a path in the manner you want. You can make it go in any direction you want, but just remember that the left most point on the leaf will attach to the beginning of the path and the right most point will
attach to the end of the path. When your image is in position (use the rotation handles on the bounding box for this), choose the Stroke Definition tool (last button in the top row of the ToolBox). If it will help you, turn on the grid lines for guidance. You will want to define the image as close to the
left and right edges of the image as possible. When you are ready to define the stroke, drag a marquee around the image with the Stroke Definition box. When you release the mouse, the same Stroke Definition box will appear as when we defined a stroke using the Define Stroke menu item. I'm
going to leave a lot of space on the right and left sides of my stroke so you can see the effect it has:

The red box around the image shows how close I got with the Stroke Definition tool. When we defined our first stroke, using the Define Stroke menu item, Expression used the bounding box as the defining area. In other words, the menu item method of defining is fine if you aren't particular
about how much white space is between the left and right edge of the image and the red box. Any white space there will show up on the stroke. What attaches to the beginning of a path is the area at the very left edge of the definition box (the red box in the image above), not the edge of the
stroke itself. I'll demonstrate by defining the stroke in the image above and applying it to a path:

Notice all the white space at both ends of the path? To avoid this, define your strokes as close to the left and right edges as possible. The red line with the arrow in the center of the Stroke Definition box represents a path to show you how your stroke will attach to paths you draw in Expression.
Compare the last two images above.

Our font stroke was a simple example. You can also create complex images and turn them into strokea. Instead of creating one, let's take an existing stroke apart and re-define it. Create a path and apply the 'longfish' stroke from the Graphics folder in the Strokes palette. With the path
selected, choose Objects > Unstructure and then Arrange > Ungroup from the menu bar.

What we did here was de-construct the stroke to bring it back to the paths use to create the stroke. Click away from the fish to deselect all the paths and then click on a few individual paths. The stroke used to outline the main body of the fish is a stroke found in the Water folder of the Strokes
palette. How do I know that? With the path selected, the stroke used on the path will appear in the Stroke Preview in the Paint Style palette. Hold your mouse over the preview window and a tool tip will appear containing the stroke type followed by the name of the stroke. (At this point you could
choose a different stroke from the Strokes palette to replace the original stroke used.)

Let's change the colors in the fish and re-define it. As we do we'll learn some new selection tricks. I'm partial to salmon colored fish so these are the colors I've chosen for my fish.

Follow along using my color choices; you can change them later if you want. If the HSL color picker is not your active color picker, change it so we can take advantage of the 'Lightness' meter. Click on the fish body and then click on either the Fill Preview or the Fill button to change the fill color.
Enter the following values in the color meters: H 10: S 100: L 76.

We want to remember this color so choose the Eyedropper from the Toolbox (shown in the image on the left). Notice the two color buttons at the end of the ToolBox. We want the second button which says 'Screen Color' when you mouse over it. With the Eyedropper tool, click on the new fill color in
the fish body and notice that a little box appears next to the eyedropper icon on Paint Style palette (below the Color Preview) filled with the color you chose with the Eyedropper tool. Switch back to your Object Select tool and click on the face of the fish. The color in the Paint Style palette changed
to the current fill color and we want to change it so click on the little box next to the eyedropper icon filled with the body color. Now the fish face is filled with the new body color, but of course we don't want it quite that dark. Change the value in the Lightness meter to 92. The face should now be a
much lighter shade of salmon. We really should change the mouth color now so click on it to make it active and then click on the eyedropper color box again to change the mouth to the color stored in the eye dropper.

Choose the Eyedropper tool and click on the fish face to place the lighter shade of salmon in the eyedropper color box. Switch back to the Object Select tool (see why I urged you to learn the shortcuts?) and click on the top fin on the fish. From the menu bar, choose Edit > Select By, put a
check mark in the box labeled 'Same Fill' and click OK to close the dialog box. Ah ha! Another way of selecting paths! (Investigate this further to see what other selection options you have). In addition to the top fin, the two bottom fins should also be selected because they contain the same fill color.
Click on the eyedropper color box to change the fill color of all selected objects to the lighter salmon color.

Obviously the person who created this stroke used a different shade of yellow for the fish tail fins because they weren't selected when we selected all objects containing the same fill color. You might keep this in mind when you create your own strokes. So go ahead and select the tail fins and
once again click on the eyedropper color box to apply the lighter salmon color. Now we're ready to define the fish stroke. Do this now, using the method we used earlier, and create a very long path. Apply your new fish stroke and notice how it stretches to fill the full length of the path.

In some cases we don't want a stroke to stretch like this. Fortunately, Expression has anchoring and repeating features to modify a stroke's behavior. Let's create a new stroke and test these features. Move your group of fish objects off to the side as we will use them again when we work with
bitmap strokes.

Anchoring Strokes:

Using the Pen tool, create a stroke 5 inches long. Choose the 'train' stroke in the Repeating folder in the Stroke palette. Set stroke width to 70 pixels and you should have 4 train cars, like this:

First, look closely at the train stroke and notice that the beginning and end of the stroke extends beyond the beginning and end of the path. You don't need to enclose an entire object to make it part of the stroke. In this case, the author of this stroke enclosed only part of the caboose and
engine. When you enclose an object with the Stroke Definition tool, enclosing only part of an object will cause the entire object to be included in the stroke.

Choose Objects > Unstructure and then Arrange > Ungroup from the menu bar to deconstruct the train into separate objects. Deselect all objects and then select the caboose. Fill the caboose with a red color. Instead of using the Eyedropper tool, select the Attributes tool under the
Eyedropper tool. With the Attributes tool, click on the caboose and drag to the train's engine and release the mouse. The Attributes tool allows you to drag an object's stroke and fill attributes to another object. Your train objects should now look like this:

Select the train car to the right of the caboose and give it a green fill color. Choose the remaining train car and give it a yellow fill color. We are now ready to define our rather colorful train as a stroke. We don't want this stroke to stretch the full length of the path like our fish stroke did so we
will anchor the caboose to the starting point of the path and the engine to the ending point on the path.

The Anchor tool is the first button in the third row of the ToolBox but you can only access this tool after you drag a marquee around the object(s) you want to define as a stroke with the Stroke Definition tool. Choose the Stroke Definition tool and drag around the train objects to display the
Stroke Definition box. Try dragging inward to capture only part of the caboose and engine like the original author did. Once the definition box appears, choose the Anchor tool (Shift-A shortcut key) on the ToolBox (below the Object Select tool).

When you choose the Anchor tool, two new buttons appear on the right side of the ToolBox, as shown on the left. These button are, from left to right, the Anchor to Start and Anchor to End buttons. With the Anchor tool, click on the caboose to select it. Then, hold down the Shift key and click on the
two wheels below the caboose, the wheel bar between the wheels, and the bar that connects the caboose to the next train car to add them to the caboose selection. (If you need to, enlarge the definition box by dragging the edges of the definition box outward and use the zoom tool to enlarge your
view of the train. You can also use the hand tool to move around inside the definition box.) Click on the Anchor to Start button and you'll see an anchor button at the beginning of the stroke in the definition box. This causes all of the selected objects to be anchored to the starting point of a path so
they won't stretch.

With the Anchor tool still active, click on the engine, the wheels and wheel bar, and the connector between the engine and the train car behind it. Click on the Anchor to End button and once again an Anchor button appears, but this time at the end of the stroke. Define your stroke and give it
the name 'color train' and save it to the folder of your choice. Make a nice long path and apply the new stroke to it. Here's what it should look like:

Well cool! Our caboose and engine didn't stretch, but the other train cars did. What we want to do with the other cars is to have them repeat. Let's fix that now. Double click on the train in the Stroke Preview on the Paint Style palette, or on the name of the stroke in the list of strokes in the Strokes
palette to bring up the stroke in the Stroke Definition box for editing. This time choose the Repeat tool which lives under the Anchor tool. When you choose this tool, notice the new buttons on the right end of the ToolBox (shown on the left). These are the Repeat and Do Not Repeat buttons. Drag a
marquee around the two cars in the center with the Repeat tool. It's ok if the two connectors are also selected, even though we anchored them originally. Then click on the Repeat button on the right end of the ToolBox.

When you clicked on the Repeat button, two bars appeared at the beginning and end of the stroke in the definition box. Where these handles are determines the point on a path where the repeat takes place. If we leave the bars where they are, the two cars will repeat from the beginning and
end of the path, on top of the caboose and engine. To avoid this, drag the first bar to the beginning of the connector between the caboose and car to the right of it and release the mouse. Do the same with the other bar, dragging it to the end of the connector just before the engine. These bars
determine where the repeat starts and ends, but we still need to anchor these cars to their starting and ending points. To do this, look at the center of each bar and notice a small pointy retangular button. This is the repeat anchor. Hold down the Shift key and click on the button in the center of the
first bar. You'll see the button turn into a button with an anchor icon on it. Do the same thing with the ending repeat bar. Your repeat bars should now look like this:

Finally, define the stroke by clicking on the Define Stroke button. The original name of the stroke will appear in the information box. Leave the original name and accept the other defaults and click the OK button. You will be prompted to overwrite the original. Choose Yes. You will see the new
version of the stroke attached to the path you made earlier. If all went well, your stroke should now look like this:

As you can see, we have the caboose and engine anchored at the beginning and end of the path, respectively, and our center cars repeated, giving us two green cars and two yellow cars. This process might have seemed complicated, but once you create a few strokes like this, you'll discover
how easy it really is. Of course this is not to say that you won't come upon objects that aren't complicated to define. The more complex the objects, the more complicated the definition process will be. Start with easy objects and work towards more complicated ones when you're ready. You'll find
two tutorials in your user manual that will help you; See Tutorials 3 and 4 beginning on page 171 of the user manual for additional information.

Bitmap Strokes

Bitmap stroke are created a little differently than vector style strokes. First, there is no bitmap definition tool on the toolbox. Instead, you select the bitmap image you want to create a stroke from and choose Stroke > Define Bitmap Stroke from the menu bar. This results in the following
dialog box:

The top half of the dialog box asks for a stroke name, the folder where you want to save the stroke, and a default stroke width. The next section gives you three options which determine how transparency in an image should be treated, if the image has transparency. The first option is to use
no alpha channel. With this option, the stroke is created from the image exactly as the image appears. This option is supposed to ignore any transparency in an image, but it doesn't on my Windows XP system (sometimes features work differently on different operating systems).

The second option is to use the image's original alpha channel (transparent areas). If the image you're defining has transparency, this option is active by default but you can change it by selecting one of the other options. If the image has no transparency, this option is grayed out and
unavailable.

The third option is to define the stroke as a grayscale image. With this option, the image is converted to grayscale with transparency applied to the white and lighter shades of gray in the image. White parts of an image will be totally transparent, with diminishing degrees of transparency
applied to shades of gray until they reach black, which will be totally opaque.

The next section on the dialog box is used for anchoring parts of the stroke and repeating other parts. We'll discuss this section a little later. Let's create our first bitmap stroke using the grayscale option.

Copy the following image and import it into Expression.

Select the image and choose Stroke > Define Bitmap Stroke from the menu bar. Notice that Expression detected this image as a grayscale image as the grayscale option is selected. Give your stroke a name. Choose a folder to save the stroke in, or create a new folder by typing in the name
of a folder that doesn't currently exist. Expression will create the directory. Before you use your stroke, create a big rectangle shape and fill it with a dark color. Choose any drawing tool, draw a path anywhere inside the dark rectangle and, with the Skeletal Stroke button active in the Paint Style
palette, choose the name of your new bitmap stroke to attach it to the path. The purpose of the dark colored rectangle is to show you that the bitmap stroke is transparent in all the right places. Change your stroke to a lighter color, or white. (Tip: To easily obtain a pure white color, click and drag
inside the color triangle all the way to, and even beyond, the upper left corner and release the mouse.) All the white parts in the original bitmap image were treated as transparent to create a totally natural brush stroke.

There's just one problem with this stroke. Choose the Freehand tool and draw a very long path and apply the new stroke. Notice how the stroke stretches and no longer looks 'crayon' like. Let's redefine the stroke and change this default behavior. Select the original bitmap image and choose
Stroke > Define Bitmap Stroke to display the Define Bitmap Stroke dialog box. Give your stroke the same name to write over the original stroke with this new version, or a new name to create a new stroke. The Grayscale option should be selected; select it if it isn't. Notice the bottom section of
the dialog box and that the image size is stated there. Below that it tells you that there is no head section or tail section and that the body section of your new stroke will be the entire length of the image. We want to change that.

In the "Body Section" drop down box, choose Simple repeat. This will cause the entire mid section of the stroke to repeat as many times as it needs to, depending on the length of the path it is applied to. In the "Anchored head section Length" box, type 70, which represents 70 pixels from the
left, or "head" section of the stroke. Notice that the head, tail and body dimensions listed above change dynamically to reflect the new values entered in the text boxes. Set the Anchored tail section Length to 70 and click on the OK button to dismiss the dialog box. Drag out a very long stroke again
and notice that the stroke no longer stretches to fit the path. Rather, the stroke is anchored at the beginning and end of the path while the mid section repeats.

What's great about the grayscale option is that you can scan natural media paint, pencil or other strokes to files, bring them into Expression and turn them into strokes easily. This is what Jessica did with her watercolor paints. You can download Jessica's stroke here. You'll find more information
on making bitmap strokes in Tutorial 9, beginning on page 187 of your user manual.

Let's create one more stroke before we move on to discuss the advantages and disadvantages of bitmap and vector skeletal strokes. This next stroke will be defined using the Use Original Alpha option. When you have a bitmap image that contains many colors, the grayscale option isn't suitable
as that option converts an image to grayscale if it isn't grayscale already. Let's go back to our salmon colored fish paths, rasterize the paths and then turn the resulting bitmap into a bitmap stroke.

Place your fish paths within easy reach in the view area and choose Objects > Bitmap > Create Bitmap from the menu bar. Your cursor will turn into a bitmap cusor. Drag a marquee around your paths, staying as close to the edges as possible (again, grid lines work well here), and release
the mouse. In the resulting dialog box, check the 'Rasterize region' option and click the OK button to dismiss the dialog box and create the bitmap. A copy of the paths now appears on your view area as a selected bitmap image.

Define this bitmap image as a bitmap stroke just like you did before, except use the 'Use Original Alpha' option this time. (Leave the bitmap image in place on your view area when you're done; we will get back to it shortly.) With this option, you have the best of all possible worlds. You retain
all the colors in the stroke, the background is transparent, and you can anchor the head and tail and repeat the body portion just as you would with the other options. When you're done defining your stroke, test it against a dark colored background to make sure the transparency is in place. You will
find that you can't change the color of this type of bitmap stroke when applying the stroke to a path. What you will get is an outline of your stroke filled with the solid color. Very unattractive.

Advantages and Disadvantages of Bitmap v. Vector Strokes

Bitmap images do not retain clarity when rasterized or imported into Expression. Move your bitmap image and notice that the original paths are below the bitmap image. Comparing the paths to the bitmap image, you can see the loss of clarity. You can, in some cases, use Photoshop filters to
sharpen the image a little but many people have problems using Photoshop filters, and many people can't get them to work at all. (This is the main reason filters are not covered in this course).

File size isn't much of a factor between the two different types of strokes. The vector longfish skeletal stroke is 25 kb in size, the bitmap version is only 23 kb. Not much of an advantage. But the file size of an Expression document can be drastically different depending one which type of strokes
are used. Consider the following vector stroke, and notice the amount of nodes it contains:

If this stroke is applied to a path that isn't perfectly straight, look how many more nodes are needed to compensate for the curve, despite how slight the curve is:

Imagine how many nodes it would take if the curve was more than just a slight curve:

Every one of those nodes adds to the overall size of the finished image. Multiply those nodes with many strokes and the image size can get rather large, and you can even cause Expression to labor if you really get carried away with vector style strokes.

One thing you can do to reduce the number of nodes on a path is to use the Smooth Path feature. Here, I've taken the stroke shown in the image above, which has been unstructured to return the stroke to it's original path, and chosen Objects > Smooth Path from the menu bar. In the resulting
dialog box, which asks for a tightness of fit value, I left the default value at 1. Here's the result:

You've already seen how a vector stroke can be dissected and changed. If you spend a lot of time making strokes and sharing them with friends, but don't want your work changed, distribute bitmap versions of the strokes. You can't unstructure a bitmap stroke.

More on Path Manipulation

Let's use the last stroke we made to investigate the remaining items on the Attributes palette that affect the appearance of a stroke. Create a rectangle shape using the Rectangle tool and apply the last stroke you made to it. Of the first 4 buttons in the upper right corner of the Attributes palette,
click the first one labeled "Continuous" on the tool tip This button tells Expression to apply the stroke on the selected object to the entire length of the path surrounding the object. Click the button just below the Continuous button, labeled "Break at Joints." This causes the stroke to start anew at
each corner node.

The three buttons following the Continuous button are the Stroke Joint buttons. Click the Continuous button again and then click the first button to the right of the Continuous button. With this button, The Miter Joint button, creates sharp corners on the stroke while the Round Joint button and
the Bevel Joint button create rounded and beveled corners respectively.

The three buttons to the right of the Break at Joints button apply only to open paths that have basic or gradient strokes applied. With any other path, these buttons appear grayed to indicate that the feature is unavailable for the currently selected object. These buttons are self explanatory.
Apply the Square Caps button, the Round Caps button or the Butt Caps button, depending on the look you want applied to the beginning and end of a path with a plain or gradient stroke.

The three buttons below the Shear slider, which do not appear grayed out in the screen shot above, are the Sausage, Ribbon and Elliptical mode buttons. To test these buttons we need a new path. Scoot your rectangle off to the side as we'll use it again in another exercise. With the B-Spline
tool, create a path similar to the following:

The image above uses the Sausage mode button, which is the default mode for strokes. Click on the Ribbon button and notice the new "ribbon" appearance:

Click on the Elliptical mode button and the stroke looks like a cross between the Sausage and Ribbon modes. The Elliptical mode allows for additional settings. Choose Stroke > Set Ellipse Ratio from the menu bar to display a value dialog box. Entering a lower value will create a style closer
to the ribbon mode and a higher value will give you a style closer to the sausage mode. The values must be between 10 and 90.

The last item in the Attributes palette we'll look at is the Dash On/Off button, which appears in the lower left corner of the Attributes palette. Click on this button and you'll see a text box appear to the right of the button. Enter "2 10" in this text box (without the quotation marks) and press the
Enter/Return key on your keyboard. This causes the stroke to take on the appearance of a dashed line, like this:

The Dash button can be applied to basic, gradient or skeletal strokes. The values you enter in the input box create the width and interval of the dash, starting at the beginning of the path, separated by a space. The first value (2) we entered set the dash width at 2 pixels and the second value
(10) set the interval between dashes at 10 pixels. The Dash value input box accepts 3 values. Enter the values 2 10 50 and see how it affects the stroke. Be sure and press the Dash On/Off button again to disable it when you are done because the dashed line setting will apply to all future paths you
create.

Did you know you can twist a stroke? Select your rectangle shape and, from the menu bar, choose Stroke > Set Stroke Twist, enter a value of 10 in the resulting dialog box, and click the OK button. If you decide to apply a new stroke to the rectangle, you'll need to reset the stroke twist
value. Expression doesn't remember your setting.

Practice, practice, practice!

There is no real homework assignment for this lesson. Once again you've been given a lot of information and the best way to retain the information is to practice, practice, practice! Try deconstructing some simple vector strokes in the Strokes palette and redefining them using the anchoring
and repeating features. Give them new colors, new strokes or patterns. Go through some of your clip art CDs as many of them contain scanned, real world paint strokes, and turn them into bitmap strokes. Better yet, scan some of your own paint strokes.

This concludes lesson 4. Next week we will work with blending paths, which we touched on in an earlier lesson, and effect lines. See you then!

All material presented in this course is ©2003-2005 Annie Ford
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Lesson 5

Effect Lines and Blending Paths

In this lesson we'll explore Effect Lines and a related topic, Blending Paths. Both features are powerful tools. Which feature you use will depend on your project. Let's begin.

Effect Lines

Effect Lines are new to Expression 3. As you'll discover, there are many uses for Effect Lines. The author of one Japanese web site used Effect Lines to create a straw hat and hair for a mermaid image. The author of this web site offers instructions for creating the hair, but you'll need to have
the instructions translated if you don't read Japanese.

Another use for effect lines is to create scratch board images, much like this one. As you work with effect lines, I'm sure you'll find even more uses for this feature. Let's begin with effect line basics.

Effect Lines can be applied to either open or closed paths. Two paths are necessary to create effect lines as the lines are drawn from one path to a second path. If you start with only one path, Expression will create a second path exactly like the original and create effect lines between them.
Let's test this.

With a new document opened in Expression, draw a path with any of the drawing tools (not the shape tools; we'll use those later). Open your Effect Lines palette by choosing Window > Effect Lines from the menu bar or by using the F12 shortcut key. Click the Create Effect Lines button in the
lower right corner of the Effect Lines palette, as shown in the screen shot on the left. Below is a screen capture of the path I started with, and below that is the path after applying effect lines to it:

 

As you can see, Effect Lines run from one path to the second path and this is why two paths are necessary. If you don't want Expression to create the second path for you, create it yourself. Delete the effect lines on your document and create two paths this time. Select both paths with the
Object Select tool (or by holding down the Ctrl key to temporarily switch to a selection cursor) and click the Create Effect Lines button. Here's mine:

Click away from the effect lines and notice that the original source paths seem to have disappeared. Expression uses the path information only when creating effect lines and discards any other information, such as any stroke, fill, or other attributes that may have been applied to the paths. In
other words, the paths from which effect lines are created are only reference paths as far as Expression is concerned. For this reason, it is important to make a copy of your paths before applying effect lines if you want to preserve them for later use.

Effect lines are paths like any other paths. You can apply strokes and other attributes to them. Click on a stroke in the Pointers folder on the Strokes palette. Choose a stroke width on the Paint Style palette so the stroke will be visible. Below is the Arrow 1 stroke with a 6 point stroke width
applied to my effect lines:

Once you create effect lines, you can ungroup the lines to work with them individually. Select your effect lines and choose Objects > Unstructure and then Arrange > Ungroup from the menu bar. Notice that not only are the effect line separate paths, but the original paths used to create
the Effect Lines are gone. Again, the original paths were only reference paths. Click on the effect line paths individually and move them to see that they are indeed individual paths.

With the shape tools, you only need one path. Expression will create a clone of the original shape, place it in the center of the original shape, and apply the effect lines from the original shape to the center close shape. Draw a circle with the Ellipse tool (make sure the "With Chord" is the active
Arc mode in the last button on the bottom right end of the ToolBox when the Ellipse tool is active) and apply effect lines using the Create Effect Lines button (you can, if you prefer, choose Objects > Effect Lines > Create from the menu bar). Below is my circle with the 'fancy arrow' stroke applied
with a 9 point stroke width:

Once effect lines are applied, the other options on the Effect Lines palette become active, as seen on the left. The meter at the top of the palette determines the amount of spacing between the lines. A higher value leaves more space between the lines and a lower value leaves less space between
the lines. Below is the same effect line object as the one above with Line Spacing set to 26:

The slider to the right of the Line Spacing meter let's you apply random spacing. With the effect lines object selected, move this slider, called the Separation Variation slider, to 50% and notice the random spacing:

The second meter, below the Line Spacing meter, sets the stroke width and it works the same way as the Stroke Width meter on the Paint Style palette. Creature House says that the Paint Style palette cannot be used to set the stroke width of effect lines, but we know different, don't we.
Reduce the stroke width using the Effect Lines palette and you'll notice that the stroke width meter on the Paint Style palette updates with the new stroke width information.

The slider to the right of the Stroke Width meter let's you vary stroke width among lines. With the effect lines object selected, move this slider, called the Width Variation slider, to 50% and notice the random spacing. Here, I've moved the Separation Variation slider back to 0% and the Width
Variation slider to 50%:

As you can see, some strokes are now wider than others.

The next set of controls on the Effect Lines palette control clustering. Clustering allows you to group sets of lines. To enable clustering, click the first button labeled 'Clustering On/Off' on the tool tip. This button turns on clustering and reveals the meters and slider in the palette shown on the left.
The first meter controls Cluster Size and the second meter controls Gap Size. The slider allows random variations to both cluster size and gap size. Experiment with different settings to see the results. Below is a circle with Clustering turn on and set to the default clustering values (Cluster Size 5
and Gap Size 3):

The next row contains the 'Control to a Point' button. We'll discuss this button a little later. For now, let's look at the two sliders to the right of this button. The first slider is the 'Start Edge Variation' slider and this meter controls how close some of the effect lines are from the first reference
path. Here's an example:

Notice that the spacing is random. The second slider, labeled 'End Edge Variation' on the tool tip, controls the spacing of the effect lines from the second path, like this:

Before examining the remaining items on the Effect Lines palette, let's work with what we've learned so far and create a flower. This exercise will give you more practice with information from previous lessons so hopefully you've done your homework! First, let's create a petal stroke.

Clear off your view area, or open a new document to work in. We will have several palettes opened so remember that if some of the palettes collapse, you can expand them using the arrow to the left of the close button at the right end of a palette. Ok, let's do it:

Choose the Pen tool and click to place the first node and double click about 2 inches up from the first node to end the path, creating a vertical path. Apply a stroke to this path and set the stroke width appropriately to dress up the petal a bit: I'm using the comet stroke from Expression 1 and I
set the stroke width meter to 75 points. In the Variable Width palette (F7 if the palette isn't visible) click on the + button to reveal the beginning and ending nodes in the graph. Click on the beginning node and drag it to the bottom of the graph and release the mouse. Give your stroke a color (I'm
using yellow) and then deselect the path. This is the result you should have:

Choose the B-Spline tool and set stroke width on the Paint Style palette to 1 point. Beginning at a point below the first point in the previous path (make sure the Do Not Append button is enabled on the ToolBox so that your new path won't attach to the first one) click out a petal shape around
the first path. I clicked a rounded edge on the left side, made zig zag clicks to create a ragged edge at the top of the petal and then continued clicking a rounded edge on the right edge of the petal, like this:

Remember to hold down the Alt key when you approach the beginning of the new path to create a sharp corner. Otherwise, you'll need to choose the Convert Node tool to convert the beginning/end node from a rounded curve to a corner node. Begin to increase the stroke width on the Paint
Style palette until the stroke on the new path is to your liking. I increased my stroke width to 14 points. Change the stroke and/or the stroke color if you want. I changed my stroke color to orange. Click on the Fill button on the Paint Style palette and choose a light color. I increased the Lightness of
the yellow color to 98. We can no longer see the first path so choose Arrange > Down One to place the second path behind the first one. You should now have something like this:

Now we need to define our petal as a stroke. Once again, direction matters. With effect lines, strokes are applied from the from the first reference path to the second one. On a circle shape, the first path is the circle shape you create and the second path is the one Expression creates in the
center of the original path. So now we know that the top of the petal should be facing to the left. Rotate your stroke to this position using the rotation handles on the bounding box and define the stroke. Once that's done, move the original petal paths out of the way, or delete them if you choose.
Remember, you can always get the paths back again as we learned in lesson 4.

Choose the Ellipse tool and drag a circle shape. Click the Create Effect Lines button on the Effect Lines palette. You'll notice that the settings on the Effect Lines palette return to their default values. Click the No Fill button and the Skeletal Stroke button on the Paint Style palette. You also need
to click the Remove Colorization button on the Paint Style palette to the left of the transparency sliders because we want the colors we defined in the petal stroke to apply. Now choose your new stroke in the Strokes palette. Nothing exciting yet, but this is where it starts to get interesting.

The settings in the Effect Lines palette will depend on the size of the circle shape you applied effect lines too. Increase the value in the Line Spacing meter until you have fewer petals in the circle shape. Start increasing the value on the Stroke Width meter until your petals get wider. Keep
adjusting the values until you have something that looks like a flower. Here's mine, so far:

My flower looks a little too uniform for my liking and if yours does also, move the Separation Variation slider to the right to make the petals appear a little more randomly spaced. Move the Width Variation slider to create random widths for the petals. Finally, move the Start Edge variation slider
to the right (not too far) so that some petals are set in a little more than other petals. Here's mine:

This is starting to look a little better, but we can improve the flower appearance by separating the petals and moving some of them forward in the stacking order. I should mention here that I deselected my flower object before taking screen shots so that you could see my results unobstructed
by the paths. Remember to keep your flower selected at all times because you can't make changes to an object without selecting it first.

When you are sure that you have made all the adjustments to your flower that you want to make from the Effect Lines palette, choose Objects > Unstructure and then Arrange > Ungroup from the menu bar to separate the paths so that we can edit them individually. Once you ungroup
effect lines, you can no longer return to the Effect Lines palette to edit the paths as a whole.

On my flower, the petals on the bottom overlap in a uniform manner. To select the very bottom petal, click away from the object to deselect all objects and then click on the path you want to edit. In my case, I will select only the bottom most petal:

Choose a petal on your flower and choose Arrange > Up One from the menu bar. This is how it affects my petal:

If the results aren't what you intended, choose Edit > Undo Up One, choose a different petal and try again. (Notice how the name of the last operation appears in the Undo menu? This lets you know what you are about to Undo. I like that.) Choose different petals and move them up or down
until you are happy with the results. You may need to choose a stacking order (Up One, Down One, etc.) more than once to get the results you want. After experimenting with different petal stacking orders, this is what I am happy with, for the most part:

Let's say that you're still a little unhappy with some of the petals. For instance, when we used the Start Edge Variation slider to set some of the paths farther away from the beginning reference path, some of the petal may now seem to be too far in or too far out. Select a petal on your flower
that you want to move and then press the arrow keys on your keyboard and watch what happens to the path. The top arrow, of course, causes the path to move upward in 1 pixel increments. The right arrow moves the path to the right, and so forth. Personally, I am very unhappy about that
bottom petal on my flower because it looks crooked to me. Since I can resize and rotate paths with the bounding box, I rotated the bottom petal and then moved the path with the 'Down' arrow key on my keyboard until that darn petal was where I wanted it. All my flower needs now is a center.

A simple way to create a flower center is to use the 'dots' stroke in the Repeating folder in the Strokes palette and use the B-Spline tool to click out a circle shape (do this on top of the flower or away from it and move it later; either way works). Change the color slightly and click out a smaller
circle shape inside the other one. Continue doing this until you are happy with the results. Then group all these shapes together and place them in the center of the flower. I kept mine simple. Here's my finished flower:

As you can see, creating a flower simple. To create different flowers, simply create a different stroke and apply it to effect lines. You might even create two or more petals and apply them to ungrouped effect lines for variation. Let's move on and explore the other items on the Effect Lines
palette. There's still a lot more you can do with effect lines.

The 'Control to a Point' button, when enabled, places a small 'Point of Focus' node in the center of an Effect Line object and this node can be moved with the Node tool. Below are two circle shapes with Effect Lines; the first has the Point of Focus turn off and the one of the right has the Point of
Focus turn on:

With the Node tool, the Point of Focus can be moved anywhere within the shape or outside of the shape. Below is a Point of Focus moved outside of the circle:

Although the Point of Focus has been moved, the center shape stayed in place, obscuring some of the effect lines. This center shape can be moved but there's a problem. You are supposed to be able to move the center shape with the Node tool but this doesn't work for most people (it was
fixed in beta testing but it's broken again). Instead, most people can only move it with the arrow keys. Try this: move the Point of Focus outside the circle shape (assuming you're following along here) and then deselect the effect lines object. With the Node tool, draw a marquee where the center
shape is to select only this shape (deselecting the effect lines object makes the source paths invisible so you'll have to guess a little here). Then click the arrow key for the direction you want to move the shape until the shape is also outside the circle (it doesn't matter if you move it in the same
direction as the Point of Focus or not). Once the center shape is out of the say, the effect lines are unobstructed and you can proceed to apply strokes, colors or settings on the Effect Lines palette as usual.

Now this is a situation where you might want to make a copy the circle path before apply effect lines. What if you now want to create a circle, the same size as the original, to place on top of the effect lines in the image above? It is much easier to make a copy of the source path in the
beginning than it is to try and recreate a circle the same size.

I mentioned earlier that it was important to make sure the 'With Chord' was the active more for the Ellipse tool before applying effect lines to a circle shape. This is because the other modes create a break in the circle shape and Expression thinks you are applying effect lines to an open path
instead of a closed on. So instead of creating a smaller clone of the circle shape and placing it in the center, it create a duplicate of the circle shape, like this:

So far we've only worked with Effect Lines to create straight paths. This has prevented us from applying fills because fills won't show up on a straight line path. We can create curved lines as well, but we need a third path to do this. Find a spot on your view area and create a circle shape and
apply effect lines to it. Apply the default stroke with a 1 point stroke width so you have something like this:

To one side of the effect lines, create a curved path with one of the drawing tools and select both the curved lines and the path, like so:

When effect lines and a third path are selected, a button in the last row of the Effect Lines palette, labeled 'Add Path Template' becomes active. Click on this button and the effect lines take on the shape of the template path (the third path), like this:

Ah ha! This probably gave you an idea of the method used by the author of the Japanese web site to create the straw hat image.

Notice that one of the effect lines in the image above has a visible path with a node where the path curves. Because effect lines are grouped together, only one path contains nodes because anything done to one node effects all the paths. This node can be edited with the Node tool. Click on the
node where the path curves, with the Node tool, and drag it somewhere below the circle shape, like this:

Click the Gradient Fill button on the Paint Style palette and choose a gradient from the list:

Look closely at the image above and you'll see that once again direction matters. Effect lines are applied clockwise to a closed path. The effect lines are opened paths and we saw in a previous lesson that a fill on an opened path runs from the beginning point on a path to the end of that path.
So in the image above, the straight edge of the gradient fill overlaps the strokes on the paths below it. Let's drag our path in the other direction:

Now when we apply a gradient fill (or any other fill for that matter) the straight edge of the fill is hidden below the path to the left of it, except for the last path:

To fix the last path, we can once again unstructure and ungroup the effect line paths and work with the problem path individually. But moving the path up or down in the stacking order won't fix this problem because the entire path will move, not just one edge of it. So, what we need to do is
this: unstructure and ungroup the path and select only the problem path. With the Node tool, click on the node that overlaps the path to the right of it so only that node is selected:

Now click the left arrow key on your keyboard until the node on the path moves to reveal the stroke on the path to the right of it, like this:

This made a slight gap at the bottom, between the two paths, so click on the bottom node with the Node tool to select it and this time click the right arrow key once to close the gap:

Perfect! As you can see, the arrow keys work on nodes just as they do on entire paths. By default, the nudge increment is set to 1 point so pressing an arrow key moves a node or a path 1 pixel in the direction of the key you press. But you can change the nudge increment to a different value.
To do so, choose File > Preferences from the menu bar and choose the General section in the drop down box at the top of the Preferences dialog box. Look in the 'Arrangement' section for a text box labeled 'Nudge increment' and change the value. The value in the test box will be different
depending on your ruler setting. If your rulers are set to points, the text box will display '1 pt' as the default increment size. Let's return to our effect line discussion.

If you want to release a 'Template' just click the 'Remove Path Template' button on the Effect Lines palette. You can also remove a template by drawing a new template path, selecting the new template and effect lines object, and clicking the 'Add Path Template' button again. This replaces the
old template with the new one.

The more curves in the template path, the more nodes you'll have on the resulting effect lines:

Don't get carried away though or who knows what you'll end up with:

Ok, we're having way too much fun here. Play with effect lines using different shapes, such as the star or rectangle tools, or create your own shapes with the drawing tools. Take a look at Tutorial 11, beginning on page 185 of your user manual, for more ideas on using effect lines. Another
excellent resource for study is 'David' which uses effect lines for shading.

Let's move on to a somewhat related subject, blending paths. We touched on this subject in an earlier lesson but let's take a closer look at the possibilities.

Blending Paths

Somewhat like effect lines, the blending paths feature also uses reference paths to create more paths, as shown in the image on the left. One difference is that the blending paths feature does not discard the reference paths. The blends between the reference paths are grouped together, but the
reference paths are not included in the group; they remain separate

Also, the blending paths feature does not have it's own palette, but rather, has it's own place within the Objects item on the menu bar. Let's do a quick exercise:

Clear your view area or open a new document to work in. With any of the drawing tools, create a path and apply a color to it. Press Ctrl-D to duplicate the path. Choose the second path, line it up about 1 inch to the right of the first path and choose a new stroke color. In the example on the
right, I've chosen a dark brown for my first path and a medium gold color for my second path. Select both paths and choose Objects > Blend Paths from the menu bar. In the resulting dialog box, type the number of in between paths you want to create. In the example on the left, I chose a value
of 6 (6 blends and 2 reference paths for a total of 8 paths). Check the 'Linear Interpolate' radio button and click the OK button to dismiss the dialog box and create the blending paths. You should have something similar to the image on the left if your two reference paths (referred to as 'source
paths' in the user manual) were similar to mine.

Choose Edit > Undo Blend and let's apply blending paths again with a larger value this time. With both paths selected, choose Objects > Blend Paths but this time enter a value of 30 in the resulting dialog box and click the OK button. This time you should have so many in between paths
that the effect looks like a shaded ribbon.

From this example, it may appear that the only thing being blended are the colors between the two source paths. Let's create different shapes with the same colors. Here, I've created a circle and a square with the same stroke and fill colors:

Applying blend paths, with a value of 4, this is the result:

Here you can see that paths can also be blended to create in between paths. Blending always occurs from the first path in the stacking order to the second path. So if I had created the square first and then the circle, my blend would be from the square to the circle.

We can even use more than two paths, and stacking order is an important consideration in this case as well. Where three paths are used, for example, blending occurs between the first and second paths and then between the second and third paths. I'll demonstrate with the following three
paths:

In this example I've used a font for the leaves and converted the fonts to paths. Each path was created in the order they appear in the image above and I've given each leaf different stroke and fill colors. In the blending paths dialog box I set the blending value to 3. Below you can see that
both the colors and shapes blended between the first and second paths, and from the second and third paths:

So far we've left the 'Linear Interpolate' radio button checked. The other option in the blending paths dialog box is 'Angle and Length' but to be honest I have no idea why you would want to use this option. Below are the same leaf paths blended with the Angle and Length radio button checked:

Good grief! Unless you're creating some sort of abstract art, you might just stick with the Linear Interpolate option!

Now let's look at some things we can do with blending paths. In this next exercise we'll create a spiral binding. Clear off your view area, or open a new document and display the grid. With the Rectangle tool, draw a rectangle shape 2 inches wide and 5 inches long. Give this rectangle shape a
fill and no stroke. With the Ellipse tool, create a tiny circle with no stroke and a white fill and place the circle one intersection to the left, and one intersection from the top, like this:

We need more copies of the tiny circle so choose the Object Select tool and hold down the Alt key as you click and drag a copy of the first circle one intersection down and release the mouse. Holding the Alt key allows you to drag a copy of an object rather than the object itself. Continue to
hold down the Alt key and drag a copy of the last circle you created until all of the intersections have a copy of a circle, like this:

Now choose the Ellipse tool and drag an oval shape 2 inches wide and 1 1/2 inches long. Give the circle the default stroke (press the number 1 key on your keyboard if the stroke is not already set to the default stroke) with a stroke width of 1 pixel and no fill. Choose Objects > Convert to
Path to place nodes along the oval shape. Then choose the Scissors tool (6th tool in the top row of the ToolBox which says 'Cut Path' on the tool tip). With the Scissors tool, click on the top node of the oval shape to cut the path at that point and then click on the right node to cut at that point. Hold
down the Ctrl key to temporarily convert your cursor to a selection tool and click away from the object to deselect it. Still holding the Ctrl key, click on the path between the two nodes you cut to select only that portion of the path (release the Ctrl key now) and press the Delete key on your
keyboard to delete the cut portion from the path and this is what you should have:

Place the spiral (the cut circle you just made) so that the right edge of the spiral is in the center of the first tiny white circle on the rectangle (shall we call it a notebook?). Take a look at this image to see what I mean:

Hold down the Alt key and drag a copy of the spiral and drop in over the last tiny circle on the notebook so you have a top and bottom spiral, like this:

We could just continue to drag copies of the spirals and place them along the edge of the notebook like we did with the tiny circles, but let's save ourselves some trouble and use the blending paths feature. Select both the top and bottom spirals and choose Objects > Blend Paths to display
the dialog box. We have 7 holes to fill so enter 7 as the value, choose the Linear Interpolate radio button, and click the OK button. Because the blending paths feature spaces the blends evenly, your spirals should be lined up with the holes in the notebook, like this:

We could have used the blending paths method to create the holes in the notebook just like we did with the spirals. Shall we jazz up our spiral binding a bit? Select all of the spirals by dragging over them with the Object Select tool. Click on the Gradient Stroke button in the Paint Style palette
and choose the 'black-white' gradient from the gradient list. Set the stroke width to 3 points. This is what you should have:

Reference Vector Tool

You've probably noticed that the in between blends run in a straight line from one source path to the other. With the Reference Vector tool you can cause blends to curve. This is a little difficult to explain so please bear with me. There is very little information on this subject in the user manual
and I've yet to find anyone who fully understands reference vectors, including myself.

The Reference Vector tool lives under the Gradient Vector tool in the ToolBox. (The lower case letter 'g' cycles through all the tools in the Gradient Vector tool group.) You must first select the object to which you want to attach a reference vector. Then, with the Reference Vector, click at the
point you want to place a reference point and drag to create the orientation. I'll demonstrate with the following two objects:

The line at the top of the image above is a guide for demonstration purposes only. First, I select the dark colored star on the left, choose the Reference Vector tool, click just above the star to place the reference point and drag at about a 45 degree angle and release the mouse. (To get a true
45 degree angle, hold down the Shift key as you drag; the Shift key is a constraint key). This is the result:

The small circle above the star is where I clicked to place the reference point and the line indicates the angle I dragged to place the orientation. The orientation determines the angle (in part) of the blends between the two source paths and the size of the blends. A reference vector on just one
of the paths isn't sufficient. I also need a reference vector on the second path. So I'll select it with the Object Select tool and attach a reference vector to it. Below is a screen shot displaying both objects selected and their reference vectors:

Now, when I choose Objects > Blend Paths and set the blend value at 8, look at the curve that results:

The angle of orientation, as I mentioned, determines both the angle and the size of the in between paths. In the example above, my angle is about 45 degrees. Notice also that the stars get smaller toward the center of the curve and then get larger toward the second source path. If I had
clicked and dragged straight up or straight down, the in between stars would be in a straight line and all the same size as though I had not placed reference vectors at all. The closer I get to a 90 degree angle, the more my shapes will curve and the more drastic will be the difference in size of the in
between paths. Here's a screen shot of reference vectors at about an 80 degree angle:

Applying the same number of blends, here is the result:

Notice how much smaller the stars are in this example than in the first example. The over all curve is effected as well, but not to any great extent. The place at which you place the reference vector will more noticeably effect the curve. In the next example, I'll put the reference vectors away
from the paths and apply the same number of blends:

Notice how much bigger the curve is. Let's see what happens if we move the reference vectors closer together:

Obviously, since my curve is now going down instead of up, it does make a difference where I place the reference vectors. Now let's put one reference vector toward the outside, which made our curve go upwards, and one toward the inside, which caused the curve to go down:

How far away from the paths you place the reference vector also has an affect on the angle. In the screen shot below, I've placed the reference vectors in approximately the same place as the screen shot above, but higher up. Here's the result:

Finally, I'll move the reference vector on the second path more toward the reference vector on the first path so you can see that the further inward the reference vector is, the more downward the curve is toward the path the reference vector is attached to:

A few things need clarifying here. First, I've said several time that I 'moved' a reference vector. You can't actually move a reference vector. To change a reference vector on a path, you must first remove the first reference vector and place a new one. To do this, simply select the path and
choose Objects > Remove Ref Vector and then choose the Reference Vector tool and create a new reference vector.

Second, while the user manual says that you can apply a reference vector to more than one object, I have not been successful in creating anything other than a straight line blend when doing so.

Finally, you can place reference vectors below the source paths instead of above them but the process works just the opposite as when the reference vectors are above the paths. For example, when we placed the reference vectors toward the outside of the source paths, the curve went
upwards. Doing this with reference vectors below the paths cause the curve to go downward instead. Likewise, placing the reference vectors inward will cause the curve to go upward when placed below the source paths.

This concludes lesson 5. The subjects we've discussed here take experimenting to fully grasp the techniques. I encourage you to experiment with different settings for both the effect lines feature and the blending paths feature. These are very powerful tools when you know the full extent of
their capabilities.

All material presented in this course is ©2003-2005 Annie Ford
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Lesson 6

Layers and Path Operations

We've learned quite a bit about creating simple objects and paths. In this lesson we will learn to create more complex objects by combining objects and paths using various methods. As you create more complex illustrations, you will want to use layers to simplify the process. Let's begin with an
overview of layers and how they work in Expression.

Layers

By default, the Mini Layer List appears on the right side of the view area when you launch Expression. In the Mini Layer List you can create new layers, delete layers, name layers and a few other things. This list is great if the image you're working on isn't too complex. For more complex images,
you'll want to use the Object List which contains all of the features of the Mini Layer List, and more. The Object List is shown on the left. As we progress through this lesson, we'll work with the Object List so you can get a better idea of how it works. Let's hide the Mini Layer List by choosing View >
Show > Mini Layer List from the menu bar. (Repeat this process when you want the Mini Layer List visible again.) Now let's open the Object List by choosing Window > Object List or by pressing the F6 shortcut key on your keyboard. Move the Object List all the way to the right side of the view
area so it isn't in your way. (The Object List won't dock with the palettes on the left). You can make the Object List narrower by dragging the edge of the Object List, but you can't enlarge it horizontally. To lengthen the Object List, drag on the bottom of the list when your cursor turns to a double
pointing cursor. Alternatively, you can drag in both directions using the slanted button in the lower right corner of the Object List.

The screen shot of the Object List above shows what the Object List looks like before an object is drawn in the view area. The view area is automatically a layer and this layer is represented as the first entry in the Object List. Draw a rectangle in the view area and give it a stroke and a fill so
we have something to work with in the Object List.

Compare the Object List shown on the left with the one shown above. The arrow, which was hollow when no objects were present in the view area, is now solid indicating the presence of an object on this layer. Other items which also appeared hollow, or inactive, are now active as well. Click on the
arrow to expand the list and you'll see an entry which represents the object on the default layer. I will refer to items under the layer as the object list and the layer itself will be referred to as the layer list. When I refer to the Object List (using capitol letters) I'm referring to the Object List palette,
not the list of objects under the layer.

The red square next to this first item in the object list means that this item is currently selected in the view area. Draw a second object in the view area and give it a different stroke and fill color. Notice that this new object is now listed in the object list and the tiny red square is now next to
this object, indicating that this object is now the currently selected object. Click on your first object in the view area and notice the tiny red square moves back to the top object in the list. Create one more rectangle shape and give it a stroke but no fill and let's look at the icons to the left of the tiny
red square.

Your Object List should now look like the one shown on the left. Notice the icon next to the tiny red square. These icons represent an object by type. The icon at the top represents a path object with a stroke and no fill. The icons below it represent objects with strokes and fills. If a bitmap object
appeared on this layer, it would be represented by a bitmap icon. A full list of icons and the types of objects they represent can be found on page 111 of your user manual. You will also become familiar with many of these icons as we create more complex objects in this lesson

One purpose of the Object List is to give you an alternative method of selecting objects. Click on the second item in the object list and notice that the second object you created in the view area becomes selected. You can click on either the icon or the text description to the right of the icon to
select the object. Now hold down the Shift key and click on the other two items to select all of the objects in the view area. Notice that a tiny red square appears next to each of the items indicating that all of the items are now selected. Click on the view area to deselect all objects. Then hold down
the Shift key and drag up or down on the list of objects anywhere except between the icon and the text description, which is referred to as the dragging method of selecting objects.

The space between the icon and the text description is reserved for the 'lock' icon and dragging there will lock the object instead of selecting it. As you move your cursor to this empty space your cursor will change from the selection cursor to a pointing hand. Click at this point to lock an object
and a lock icon will appear in this space to remind you that the item is locked. (Why an unlock icon doesn't fill this space when an item is unlocked is a mystery to me). You will remember from a previous lesson that you can right click on an object in the view area and choose 'Lock Object' from the
context menu. Locking an object this way will also cause the lock icon to appear next to that item in the Object List. You can switch back and forth between locking and unlocking objects from both places.

As you might imagine, if you created a lot of objects on one layer, the list of objects would grow rather large. If those objects were of the same type, an object might be hard to find. One method of finding an object is to right click on the object to bring up a thumbnail of the object, as shown on the
left. (Right clicking on a layer will give you a thumbnail of all items in that layer.) Be aware that right-clicking will also select that object. If you know that you will be creating many objects on one layer, you can add a note to objects you want to find easily. To do this, double click on an item in the
object list to launch the 'Path Properties' dialog box, enter a description and click the OK button. Notice that the description you entered appears next to the text description. You can type a lengthy description, but only as much of the description as will fit in the description area will appear. Double
click on the item again to edit the description in the Path Operations dialog box. When an item you double click on to get the description dialog box is something other than a path, the dialog box will display the name of the type of item, such as 'Image Properties' for bitmap objects.

In previous lessons we talked about object stacking order. The first object you create in the view area is always on the bottom of all objects you create after that and the last object you create will always be on top. You've probably noticed that this stacking order is listed in reverse in the
objects list. The first item you created in the view area is the last item in the list and the last item you created in the view area is at the top of the list. You can change the stacking order of objects in the view area by dragging the items up or down in the object list. Let's do it. Click on the last item
in the object list, by clicking either the icon or the text description, and drag it up to the top of the list and release the mouse. A blue colored line will follow your cursor as you drag to show you where the object will land when you release the mouse.

In lesson 5 you learned how to drag a copy of an object by holding down the Alt key while dragging the object. This technique also works in the object list. Try it. Hold down the Alt key (Option key for the Mac), click on an object, drag to where you want the duplicate to be in the list and
release the mouse. It will appear that nothing happened in the view area. This is because the copy, or duplicate if you prefer, is on top of, or below the object you copied in the view area so it isn't readily apparent. Click on the object you made a copy of in the view area and click an arrow key on
your keyboard to move it so you can see the copy above or below the original object.

Let's look at the buttons at the bottom of the Object List, starting with the last button. As you mouse over the buttons, tool tips appear. Click on the last button labeled 'Collapse All' on the tool tip and notice that the objects listed in the current layer collapse. This is handy if you have a lot of
layers containing many items and several layers are expanded. It might be easier, at times, to just close everything and start fresh. When a layer is expanded to reveal the object within the layer, and more objects are listed as will fit within the Object List palette, a scroll bar will appear on the right
so you can scroll through the list.

Click on the first button at the bottom of the Object List to create a new layer and notice that the new layer appears on top of the default layer. The gray colored highlight on this layer means that this layer is active and anything you create in the view area will be created on this new layer. When you
create a new layer, the layer will appear above the active layer, but you can change this behavior in Preferences so that a new layer always appears at the top of the layer list. To do this, choose File > Preferences and, in the General section, remove the check mark in the box labeled "Create new
layer above current layer."

With the Ellipse tool, drag out a circle, holding down the Shift key if you want a perfectly round circle. Give the circle a white stroke color and no fill. Expand this layer by clicking on the arrow to the left of the new layer item to view the object in this layer. Notice that the icon is an ellipse shape
and the text description indicates the "With Chord" as the active arc mode for this ellipse object. Change the arc mode on the ToolBox to Pie Mode and draw another circle. The item in the list for this object should reflect the new arc mode. If you remember our discussion on creating circle shapes in
an earlier lesson, I mentioned that once you set an Arc mode and draw a circle or oval, you can't change the Arc mode. Well you can change it in the object list. Double click on the new Pie Mode circle and notice that the resulting dialog box gives you the option to change the Arc Mode for an
existing object. Very cool; a context sensitive object list!

Let's get rid of the second circle shape. Click on the top item in the Object List (which is the last circle you made) and hit the delete key to delete the object. This doesn't automatically select another object on the layer so click on the only remaining object in the list. A circle with a white stroke
and no fill would be very hard to find in the view area so the Object List comes in handy for this. Notice that the path on this circle is green instead of the red color we are used to. Click on the Collapse All button so only the layers are visible in the Object List and notice the different colored squares
to the right of the expansion arrows. These colored squares represent the layer colors and the paths on each layer will be the color assigned to the layer.

Click on one of the first objects you created on the first layer (the red layer) and notice that the red layer becomes active in the Object List and that the path color on this object in the view area is red. You aren't stuck with red if you want another color. Double click on the red layer in the
Object List (labeled "Layer One" to bring up the Layers Properties box. In the Layer Color section, move the RGB sliders until you find a color you like. As long as we're here, let's give our layer a more descriptive name by typing "Rectangles" in the Name box. Click the OK button to dismiss the
Layers Properties box and notice that the new name appears in the layer list and the colors on the paths in the view area are now the new layer color. You can also launch the Layer Properties box using the 5th button from the left at the bottom of the Object List. When using the button, the Layer
Properties box that displays will be for the layer that is active when you click the button. Click on Layer 2, click on the Properties button and give this layer the name "Circles" and close the properties box.

Notice that an icon appears in the red box on the 'Rectangles' layer, as shown on the left. This indicates that an item within the layer is selected. If you select the circle on the Circles layer, the icon will appear in the green square on that layer. The only way to see which item within the layer is
selected is to expand the layer and look for the tiny square next to the selected item (note that the tiny square is also the color assigned to the layer). Another way to find items is to click the Locate Object button, the third button from the left at the bottom of the Object List. This will cause the
layer to expand and the selected object to appear in the center of the screen. Don't be alarmed that the view area turns gray. Clicking on the object, or an item in the Object List will cause the screen to turn white again. I suppose this is just Expression's way of highlighting the object so you won't
miss it.

When an object is selected in the view area, clicking on the Zoom button (the third button from the left at the bottom of the Object List) will also cause the selected object to appear in the center of the view area but at a much larger size. To return to normal view, use any method you prefer,
such as clicking the Home key on your keyboard (or Shift-Home for center view), using the Zoom tool while holding down the Alt key as you click on the view area, or by using the Zoom button in the lower left corner of the view area.

The second button at the bottom of the Object List is the Delete Layer button. When clicking this button, you will be greeted with a confirmation box. If you click OK, you can get the layer back by choosing Edit > Undo Remove Layer from the menu bar.

Let's look at the remaining layer icons in the Object List. Next to the colored square, indicating the layer color, is the lock icon which allows you to lock the entire layer. Clicking on the button repeatedly toggles between locking and unlocking the layer. The eye icon toggles between making the
objects on the layer visible or invisible. The pencil icon tells you that the layer is active and the text next to the pencil icon is, of course, the name of the layer.

Finally, double click on a layer to bring up the Layer Settings dialog box and notice the check box labeled "Frozen" at the bottom of the dialog box. There may be times when you create so many objects that Expression's redraw rate will slow down. The "Frozen" feature lets you temporarily
rasterize the objects on a layer to speed things up again. You'll notice that items on a frozen layer won't look as sharp as before, but this is only temporary. Uncheck the box when you want to return the objects to their original state.

We are finally ready to move on and create complex objects. Leave the Object List visible so we can continue to work with it. Ready?

Compound Objects

A compound path is a path made up of two or more sub-paths, each with its own starting and ending nodes. Click on the circle in the Circles layer, using the object list if you can't find the object in the view area. Give the circle a fill. With the Ellipse tool, create a new circle on top of the first
circle. Hold down the Shift key and click on the first circle in the object list to select both circles. Now choose Arrange > Align > V. Centers and then Arrange > Align > H. Centers from the menu bar to align the circles vertically and horizontally. Choose Objects > Compound Object > Make
from the menu bar. Now look at the object list and notice that you only have one object where you previous had two. The item for this object says "Two sub-paths" indicating that your object is a compound object. What we've done here is to create one object by cutting the smaller shape from the
larger one to create a donut shape with a transparent center. Choose Objects > Compound Object > Release to separate the objects back to their original form and your object list once again lists the two objects separately.

Experiment with compound objects. If you give your objects different strokes and fills, the final compound path will inherit the stroke and fill colors of the bottom most object. You'll notice in the donut shape that the stroke and fill from the center object was discarded.

Path Operations

Path operations are to Expression what Pathfinder is to Illustrator. Path operations allow you to form paths by adding to, subtracting from, or dividing by other paths. Let's start by creating a banner. In the Objects List, create a new layer and name it "Banner." Hide the other layers by clicking
the Eye icon in each layer. Make sure the Banner layer is active by clicking on it.

We need a little control here so let's display the grid (Shift-G or View > Show > Grid) and turn on Snap to Grid (View > Snap > to Grid). Set your rulers to points. Decide on a color for your banner and select it in the Paint Style palette with the Fill button active; I'm using a brown color.
Let's create a stroke first. With the rectangle tool, draw a rectangle about 3 grid spaces long and 1 grid space deep, and give the rectangle a fill and no stroke, like this:

With Snap to Grid enabled, you only need to get close to a grid intersection to have the shape snap to a grid line or a grid intersection. Click on the brown rectangle with the Color Dropper tool to place the color in the Dropper Content box so we can get this color back when we need it again.
Click away from the rectangle and choose a white color (or a complimentary color if you're using something other than my colors). Draw a thin rectangle in the center of the first one, by starting the drag close to the grid line where the first rectangle starts and ending close to the grid line where the
first rectangle ends. If the white rectangle isn't centered, use the arrow keys on your keyboard to space the rectangle evenly between the top and bottom of the first rectangle. You can also use the alignment feature like we used earlier if you'd like. This is what you should end up with:

Now define these rectangles as a stroke. The Stroke Definition tool responds to the Snap to Grid feature so you only need to get close to the grid intersections for this tool to snap to the edges of the rectangle. Name your stroke and save it in the folder of your choice. Delete the rectangles if
you want as we don't need them now.

Now click on the Dropper Content box to place the color back in the fill properties and drag a large rectangle shape. Mine is about 450 points long and 150 points high. (Remember that if the Object List gets in the way, press the F6 key to toggle between showing and hiding the list). Then
choose the Ellipse tool and, staying close to the grid lines, drag an oval shape taller than the rectangle but shorter in length, like this:

Using Snap to Grid saved us the trouble of aligning these object with the alignment menu options. Next, select both objects by either dragging around them with the Object Select tool or by using the Object List. With both objects selected, choose Objects > Path Operations > Unite from
the menu bar to join the two shapes. Click on the Skeletal Stroke button on the Paint Style palette and choose the stroke you made earlier. Adjust the stroke width so you have something like this:

Choose the Text tool and type something on your banner. (Notice that the icon in the Object List for this object is a letter T to represent a text object). Select the text with the Object Select tool and change the color to white. Let's warp the text to fit our banner. With the text selected, choose
Arrange > Make Warp Group from the menu bar to place a grid over the text. You'll notice that the grid is the same as the layer color. The points on each intersection of this grid are nodes that you can edit with the Node tool. Select the Node tool, click on the node just above the center of your
text and drag upwards to almost the top of the banner, like this:

Then release the mouse and notice how the text is warped:

Now grab the node just below the text, again in the center, and drag down to almost the bottom of your banner and release the mouse. Drag any other nodes until your text is warped to your satisfaction. Here's mine:

Ok, well maybe this isn't the greatest piece of artwork you've ever seen, but at least you know how to warp objects. If you are unhappy with the warp, you can reset the warp grid by choosing Objects > Warp Mesh > Reset Grid and start over. To get more grid lines on your warp grid for
more localized warping, choose Objects > Warp Mesh > Inc Resolution as many times as necessary. To decrease the number of grid lines, choose Objects > Warp Mesh > Dec Resolution.

Once you are happy with the results of your warp choose Arrange > Ungroup and your text will become individual paths, but the paths are still grouped together. Display the Object List (F6), if it's hidden, and open the Banner layer to see the objects listed under that layer. The icon for the first
item (top most object in this layer) is the warp group icon but no text description follows. To remember what this is, double click on this item and type "Warped banner text" in the 'Group Properties' box and click the OK button to dismiss the box and display your note. Click on the second item
under the Banner layer to see that there is only one object made from the two objects we united to create the banner shape. (Don't be concerned that you see only one layer displayed in the screen shot on the left. I deleted the other two layers.)

Back minus Front: One or more paths can be used to cut parts away from a bottom most path. Let's test the Back minus Front path operation and make a gear shape. Either work in the same layer or create a new layer. Create a circle shape with a light gray color and no stroke. Notice that
with the Snap to Grid turned on, it's easy to create circle shapes without holding down the Shift key. When you drag, just make sure you drag down as many grid sections and you drag to the right or left. My circle, for example, is 5 grid spaces both vertically and horizontally:

Duplicate the circle and reduce the size of the duplicate to less than half the size of the original. Place the duplicate on top of the original circle. Notice that it isn't very easy to drag the duplicate in place because it wants to snap to a grid. There's two things you can do. Either move the
duplicate with the arrow keys on the keyboard, because they don't respond to the Snap to Grid, or choose Arrange > Align > V. Centers and then Arrange > Align > H. Centers from the menu bar as we did before. Once you deselect this center circle shape it will be hard to find since it is the
same color as the object below it. You can either double click the item in the Objects List and give it a name, or change the color so you can see it. Color doesn't matter in this case because this object will be used to cut a section from the bottom object.

Next, with the Ellipse tool, create an oval shape at the top of the circle, like this:

Choose the Rotation tool and click in the center of the larger circle (which now has a smaller circle on top of it) to place the center of rotation point. Open the Transformation palette (F9) and enter a value of 40 degrees in the Rotation Angle meter. Click the Apply to Duplicate button 8 times so
you have this:

Select all of the objects and choose Objects > Path Operations > Back minus Front and this is what you get:

Lets give our gear a bit of a 3d look. Hold down the Alt key and drag a duplicate of the gear shape just slightly in one direction (not totally away from the original). Change the fill color of the duplicate to a darker gray. Look in the Object List for the object (remember that it will have the tiny square
next to it) and place it below the original gear (the lighter one) by dragging it above the original, as demonstrated in the screen shot on the left. Hold down the Shift key and select the lighter gear object in the Object list so that both gear objects are selected. Then choose Arrange > Align > V.
Centers and then Arrange > Align > H. Centers to align the objects. Now click on the darker gear in the Object List (which is now the second item from the bottom) and click the right arrow on your keyboard once and the down arrow on your keyboard once. Deselect the objects and this is what
you should have:

From all of this you can see that more than one path can be used to cut away parts of the bottom most object.

Front minus Back:

As you might have guessed, Front minus Back works just the opposite of Back minus Front (sort of). Let's test this by making another banner. Open a new layer and name it Banner 2. Display the grid and turn on Snap to grid, if you haven't already. With the Ellipse tool, draw a circle that fills 4
grid spaces. Make 3 copies and space them apart so you have this:

Now create a rectangle on top of the circles, like this:

Select all objects and choose Objects > Path Operations > Front minus Back to cut the circles from the top rectangle shape. You should now have this:

Looks good so far. Now let's apply our stroke to it, the striped stroke we made earlier. This is where you're going to notice some serious problems:

For a reason unknown to me, when using the Back minus Front path operation the corners are sharp, but when using the Front minus Back operation, some of the corners are rounded. This is problem number one. The other problem is that the stroke doesn't meet in the upper left corner. We
have a few options available to fix this. We could undo the path operation, move the rectangle to the back and apply the Back minus Front operation, but this would fix only one of our problems. Or, we could convert the curved nodes to corner nodes. Let's do the second option. But instead of
choosing the Convert Node tool, choose the Node tool and hold down the Alt key as you click on the curves, or rounded corners, to convert them to square corners. (Holding down Alt key temporarily turns the Node tool into the Node Convert tool.)

Lucky for us this method fixed both problems. Our corners are square and the stroke wraps seamlessly around the object. Because you will occasionally run into the problem of having a stroke break at a corner, you'll need to know how to fix it. Here's another banner using the Back to Front
path operation. Notice that once again the stroke doesn't meet, but this time it appears in the bottom, left hand corner.

This problem surfaces once in awhile with a path operation so we might just as well learn how to fix it. To do this, we're going to set a new starting point since it is where the starting and ending point meet that is causing our problem. Remember that on a closed path, the beginning and ending
points on a path are in the same place. In this case, the beginning and ending points are in the bottom, left corner where the stroke doesn't meet.

With the Add Node tool, I'll place a node at the top of the path, like this:

This is where I want my new beginning point, so I'll choose the Start Point tool which lives under the Cut Path tool (5th tool in the second row of the ToolBox). With the Start Point tool, I'll click on the new node I placed at the top of the path. When you choose the Start Point tool, the cursor is a
slanted flag and as you move the cursor towards a node, the slanted flag cursor will turn to an upright flag cursor to let you know that you can click to set a new starting point, like this:

Once I click on this node with the Start Point tool, my node changed to the new starting point and since my path is a closed path, the starting point is also the ending point:

In the image above you can see the stroke width handle now at the top of the path instead of the lower left corner. Notice also that the stroke now runs the full length of the path, unbroken. It would be nice if we didn't have problems, but at least we know that we can fix problems when they
arise.

Unite: The Unite operation takes two or more paths and joins them together to form one path, eliminating the parts of the paths that overlap. In the event that the paths have more than one stroke and/or fill, the resulting path will inherit the stroke and fill attributes of the bottom most path.
Let's create a heart shape and test the Unite operation. Choose the Rectangle tool and set the fill color to red and select the No Stroke button. Click on a grid intersection and drag a square shape 3 intersections wide and 3 intersections long, but don't release the mouse just yet. Hold down the Ctrl
key and continue to drag downward to create a diamond shape, like this:

Click away from the diamond shape to deselect it and choose a different fill color. Then choose the Ellipse tool and drag out a circle 3 intersections wide and 3 intersections long, above and to the left of the diamond shape, like this:

Using the arrow keys on your keyboard, nudge the circle shape toward the diamond shape so you see no sharp edges on the top, left side of the diamond shape, like this:

Choose the Object Select tool and hold down the Alt key as you drag a copy of the circle shape to the other side of the diamond shape and once again use the arrow keys to nudge the duplicate circle into place, like this:

Now select all of the objects and choose Objects > Path Operations > Unite to join all the shapes into one shape and you'll get this:

Because the fill color on our bottom most object was red, the final heart shape inherited this color and discarded the others. Just for fun, let's break this heart. Disable the Snap to Grid so we can place our path nodes where we want them without interference from Snap to Grid. Choose the
Polyline tool (click the lowercase w key twice) and choose the No Fill button. All we want is the path with no attributes. Now click out a random zig zag path that runs through the center of the heart, like this:

Select both the heart shape and the path and choose Objects > Path Operations > Divide to separate the heart using the zig zag path as the dividing line. Click away from the objects, then click on the right side of the heart and click two or three times on the right arrow key on your
keyboard. This is what you should have:

Intersection: The Intersection operation works just the opposite of the Unite operation, in that it eliminates everything except the parts of the paths that overlap. With the Ellipse tool, draw two circles, the first one red and the second one blue, and move them together so that they overlap.
With both objects selected, choose Objects > Path Operations > Intersection and notice that once again the attributes of the bottom path were applied to the resulting path, and that the resulting path is the shape of the two paths where they overlapped:

Divide: We saw the divide operation when we broke our own heart (giggle). Let's get a little more practice and make a web button. Turn Snap to Grid on again and draw a square shape with the Rectangle tool. Fill it with any color; I'm using aqua. I'll make mine large because I can reduce it in
size later. My square is 3 grid spaces wide and 3 grid spaces long. Make a copy of the square and scoot it off to the side for now. Next, draw two diagonal lines with the Line tool through the first square shape and then select all three paths, like this:

Choose Objects > Path Operations > Divide to divide the square into 4 triangles. Click away from the objects and then click on the left most triangle and give it a slightly darker color. To do this, reduce the value in the HSL Lightness meter on the Paint Style palette. Do the same with the
bottom triangle and the triangle on the right so you have something like this:

Select the other square shape that you moved off to the side and increase the Lightness value by about 10 percent. Reduce the size of the square and place it on top of the four colored triangles. Well wait just a minute here! When we created the first square, and made a copy of it, the copy
should be on top. But now it's on the bottom. What happens when you create a path using a path operation is that the resulting path or paths are new paths so they move up in the stacking order. Fine. With the duplicate square selected, choose Arrange > To Front on the menu bar to bring the
square back to the top and you now have a finished web page button:

You can create objects with even more depth by placing squares together before dividing them. Can you guess how the following button was created?

Ok I'll give you a hint. I placed two squares together and divided them with diagonal lines as we did with the web page button. This gave me 8 triangles. I darkened the bottom most triangles in a counter clockwise direction and darkened the inner triangles in a clockwise direction. Then I
created a third square in a lighter color and placed it on top. It looks like a picture frame. Instead of a colored square in the center, how about placing a bitmap image there?

With all of our path operations, the excess parts of the paths were eliminated. You have the option to keep these excess parts if you want to by changing a setting in preferences. To do this, choose File > Preferences and choose the General section. Place a check mark in the box labeled
"Path Operations: Keep Originals" in the Objects section and click the OK button to close the preferences box. Now, when you apply a path operation, your original paths will remain.

Clipper Paths

A clipper can be thought of as a mask. Instead of cutting away unwanted parts of an object, a clipper simply hides unwanted parts. Let's create a new layer and name it Clipper. Hide all other layers. Then dig through your favorite photos and find a bitmap image to use for this exercise. If you
don't have digital images, either copy the following image, or find one at the 315 dpi web site, which is where I got the following image.

Bitmap images can be combined in the same layer with path objects. Insert the bitmap you want to use for the exercise by choosing File > Insert Bitmap from the menu bar, navigate to your image, and choose Open from the Insert Bitmap dialog box. First, notice that the image is below a
grid much like the warp grid we used earlier. This grid is indeed a warp grid which can be edited using the Node tool like we did earlier. The only difference is that you didn't have to do anything special to get this grid; it just appears when you open a bitmap image.

Expand the Clipper layer in the Object List to see how a bitmap is represented. Notice that the icon is a bitmap icon followed by the size of the image as a text description. If your image isn't quite the size you want, click on the image with the Object Select tool and drag the resize handles to
enlarge the image or shrink it. The original dimensions of the image will not change in the bitmap item in the Object List, however.

Now choose the Rectangle tool and drag a rectangle or square, with a white fill and no stroke, on top of the image a little smaller than the size you want the finished image to be. I'm going to draw my rectangle a little smaller than the flower, like this:

In the Soft Edge Width meter (below the row of fill buttons on the Paint Style palette) enter a value of about 30 (your objects might require a different value). Then click the Choose Fringe Texture button (to the left of the Soft Edge meter) and choose a fringe; I'm using the ripples01.bmp file.
Set the option in the Fringe Fill dialog box to repeating so the fringe runs all the way around the rectangle. The reason I made my rectangle a little smaller than I wanted was because the soft edge and fringe fill would add a little bulk to the rectangle. You should have something like this:

With the Object Select tool, hold the Shift key and click on the bitmap image so that both the rectangle and the image are selected. Notice that two objects are listed in the Object List and that they are both selected. From the menu bar, choose Objects > Clipper > Make with Top Path. Oh
cool! Deselect both objects by clicking away from them and notice that your image now has a ragged edge, like this:

Click on the image again and notice that both objects are still there and that nothing was removed. Only part of the bitmap image was hidden. This is what the Clipper does. Look in the Object List and notice that there is only one item there and the icon type is a clipper icon. Double click on
this item and give it a description if you'd like as no text description was added automatically.

By now you should know whether layers will help you create your artwork. But whether or not you'll want to use the Object List, as opposed to the Mini Layer List, might still be unclear. Let's look at what the Mini Layer List has to offer.

Mini Layer List

Press the F6 shortcut key to hide the Object List and choose View > Show > Mini Layer List from the menu bar. As you can see by the image on the left, the Mini Layer List offers very little compared to the Object List. Notice the lack of an expansion arrow. You can't view the objects on the
layers. You can hide and lock layers and a small icon lets you see which layer is active. You can drag layers up and own in the list by dragging the colored square on the right end of each layer. The three buttons at the top of the Mini Layer List let you create a new layer, delete a layer and open the
properties box. You can also double click on a layer to give the layer a name but you can't see the layer name unless you mouse over the layer to display a tool tip. Which palette you use to work with layers will probably depend on the image you're working on.

For more practice with layers, see Tutorial 2, Effective Use of Layers, beginning on page 167 of you user manual.

Wrapping it up

This concludes lesson 6, the last lesson in this course. You now know enough about Expression to create great artwork. There is much more to learn about Expression but cramming all that Expression has to offer in one six week course is simply impossible. Therefore, I have given you the most
important features that you need to work effectively. I sincerely hope you will explore on your own to learn about the other great features Expression has to offer.

Thank you so much for taking my Beginning Expression 3 course!

I've enjoyed having you here!

 

All material presented in this course is ©2003-2005 Annie Ford

https://web.archive.org/web/20060205173236/http://www.intuitivmedia.de/index2.htm
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